Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying to install ionCube onto my server but have not been having a lot of luck! My server is:

Windows 2008 64bit

PHP 5.3.14 Thread Safe disabled running as FastCGI

In my PHP.ini I have :

zend_extension="C:\Program Files (x86)\PHP\ext\ioncube_loader_win_5.2.dll"

The path is correct. The DLL is from the x86 NONTS VC9 version of ionCube and PHP is using the MSVC9 (Visual C++ 2008) compiler though I have also tried using the x86 NONTS VC6 version of ionCube.

I'm not getting any error but I'm also not getting ionCube when using phpinfo():

This program makes use of the Zend Scripting Language Engine: Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

Apart from the mail application pools I have also set all the applications in the application pool in IIS7 to use 32bit mode.

I don't know if FastCGI is running under 64 or 32 bit mode nor how to switch it or whether it would make a difference?

I know it can be a problem installing ionCube onto 64bit Windows but I have also come across threads whereby other people have also [somehow] managed to get it working but even though I seem to be doing the same as them I still can't get it working.

share|improve this question
add comment

1 Answer

For anyone else having this problem, apparently for PHP 5.3 I needed to be using the 5.3dll, so:

zend_extension="C:\Program Files (x86)\PHP\ext\ioncube_loader_win_5.3.dll"

and also it needed to be the VC6 version of ionCube not VC9.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.