Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using my backup computer as a server. It's running Debian and I want to kill everything gnome related to save memory. I'm accessing remotely through ssh.

Any ideas?

share|improve this question
1  
By "killing" you mean disabling for a moment, or removing it entirely? –  slhck Oct 12 '12 at 9:13
    
Disabling for a moment. Shutting it down, if you will. –  CptAJ Oct 12 '12 at 9:16
1  
which debian release is it? –  artistoex Oct 12 '12 at 9:30
    
It's debian 6.0.4 –  CptAJ Oct 12 '12 at 9:40

1 Answer 1

up vote 4 down vote accepted

Your Gnome Desktop Manager Session is running in the Xserver. Both are just normal services (daemons) your system is starting at boot.

It seems, that X is a child-Process of the Desktop Manager in Debian/Ubuntu. So you have to stop that one (On Debian this might be gdm, on Ubuntu ligthdm) You can stop gdm for this session by using its init-script, with sudo or as root:

/etc/init.d/gdm3 stop

Or you can remove it from the list of daemons started:

update-rc.d <daemon> disable

See: http://wiki.debian.org/Daemon

If you are not sure which desktop manager is in use, you can either look for the scripts in /etc/init.d/ or you can type

ps -eF | grep dm

to search for all running processes containing "dm" (this might yield much more than just your dm though).

share|improve this answer
    
No, that didn't work. Still running like normal. –  CptAJ Oct 12 '12 at 9:22
1  
Ah I see, I just tried it. The thing is, if you stop a service, its "children" will be stopped too. I thought it was X -> gdm/lightdm -> gnome/other. You have to stop the login manager process. It depends on your Debian version. For Ubuntu and Raspbian its lightdm, but I guess you will see a script called "gdm" in /etc/init.d/. That's the one. /etc/init.d/gdm stop –  Benjamin Maurer Oct 12 '12 at 9:28
    
There we go! /etc/init.d/gdm3 stop did the trick. Thanks! –  CptAJ Oct 12 '12 at 9:42
    
But it will come back after a restart. For a server, I would deactivate the service with update-rc.d –  Benjamin Maurer Oct 12 '12 at 9:51
    
Could you edit your answer to include the working commands? –  slhck Oct 12 '12 at 10:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.