Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 4 desktops running Windows Server 2008 32bit version.

I created some shares in all these machines. My program gets files from these machines (like \machine1\abcd). The machine names mentioned in the program and the actual machine names doesn't match and I can't change either program or machine names.

So I mapped the machine name used by the program to the local IP address of the machine using "hosts" file. Everything works fine, but, when I try to access a share in a machine using local machine's name, Windows asks for a username and password. (I tried entering username and password but its not working). But when I try to access the same share using local machine's IP address, its opening.

Let my machine names be m1, m2, m3, m4 and my program refers to them as mb01, mb02, mb03, mb04.

When I try to access a share in mb01 from mb01(m1) as \\mb01\share1, Windows asks for username and password. When try to access shares in other machines everything works perfectly.

I want to access share in local machine without getting prompted for password. How can I achieve that? Edit 1: I am actually using as \\mb01\share1. Typo in question.

share|improve this question
    
how about \\mb01\share1 - double slashes – jet Oct 12 '12 at 13:08

I just asked a similar question, and someone was able to give an answer that worked! See this question.

Specifically, you add the registry entry described in this WindowsITPro article, then just restart the Server service.

You cannot ping, because this is strictly a NetBIOS thing, not a TCP/IP thing, but you can now get to your shares using the 'alias' name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.