Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have that mouse connected to my thinkpad via usb. It has worked for years. Recently when I have the mouse inactive over text, at times the cursor begins to move to the left in little short regular bursts.

As the computer is new I'm not sure if this is a mouse problem, usb connection problem or a computer ptoblem.

Any direction will be appreciated.

EDIT: I tried everything but the obvious. I had a dark surface for the mouse to be on. I changed the colour of the surface - problem solved.

Thanks everyone.

share|improve this question
It happens quite often to me; I've had the same bahaviour both at home and at work, with completely different PCs and mice. – alex Sep 29 '09 at 19:39

7 Answers 7

up vote 2 down vote accepted

I think you should use a Plain coloured/ Single coloured mouse pad

Imagine a Black and White mouse pad. Your optical lens is on the white part. When you move the mouse to the black part the sensor senses depth and thats why the cursor moves irregular.

Try it,it should work

share|improve this answer
I accepted this answer, with a comment, but somehow my comment got erased. This is the gist. It took me a bit of time to understand this, but this IS the solution in my case. Having the optical mouse on a dark surface causes it to "lose focus" and start to move. All fixed. Thank you. – Xavierjazz Oct 9 '09 at 3:06

I had the same issue. It turned out there was some hair, or dust inside the optical sensor plastic bit. By blowing off on it, the dust was gone and the mouse cursor did not move again.

share|improve this answer
So far, this seems to have cured the problem. I'll give it another 12/16 hours and if its solved, I'll accept you answer. Thanks. – Xavierjazz Sep 30 '09 at 1:46
Well, the problem is back. I may have identified the real cause though - I'll report back in 24 hours to let you know. – Xavierjazz Sep 30 '09 at 19:35

Does the problem occur when you're typing? I often have a similar problem (but to the right) when I'm typing with my hands brushing the touchpad on the my Thinkpad (T60).

share|improve this answer
Thank you. I have my pad turned off for that reason. – Xavierjazz Sep 30 '09 at 0:20
It was worth a shot. – C. Ross Sep 30 '09 at 12:09

You might try to clean the mouse, if it has a ball tracker.

However, and since you say the mouse is a few years old, my experience with mouses is that when they develop a mind of their own, it's time to get a new and more obedient mouse.

share|improve this answer
"a new and more obedient mouse". Are they called rats? – Xavierjazz Sep 30 '09 at 0:21

Cleaning the mouse is a good idea. I doubt it's USB related. I also had cheapo, no-name optical mouse that would do that by itself. If it's annoying you, there are many good, inexpensive mice available.

share|improve this answer

I exactly had the same problem, what I did was wiped the touch pad with a wet paper towel, that is it. Everything fell as it was and the mouse stopped running all the way to the right corner of the screen.

share|improve this answer
This is not an answer to the original question (which asked about a USB mouse not a touchpad) – DavidPostill Sep 2 '14 at 17:02
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Moses Sep 2 '14 at 17:09
This does answer the question. Touchpads and trackpoints aren't always disabled when a mouse is connected and they can cause pointer drift. I think we should keep this answer because it may actually help someone. – gronostaj Sep 2 '14 at 18:12
I don't think cleaning a touchpad when it is not being used will stop pointer drift ... in addition op has said I have my pad turned off in another comment. – DavidPostill Sep 3 '14 at 5:26

Had this issue just before on Windows 7 64bit however my mouse moved to the right not the left, was concerning when it happened as it's a Razer Naga mmo expert mouse (with a 4G laser) not some cheap one.

First thing I did was clean out the bottom of the mouse and no luck then I grabbed my old mouse and tried that one and the pointer continued to do the exact same thing (move slowly to the right every now and then) so I then restarted the computer and well the mouse no longer moved on it's own however I found the sensitivity of the mouse was off like it had been cut in half so went into razer synapse and increased the DPI to the max at 8200 up from the normal DPI of 4600 and still felt a little slow (and weird normally at that DPI I can't control the movement of the cursor) so went into the mouse settings in control panel and the sensitivity was only at 50% which I swore I turned it up max with my last mouse, cranked it up to 100% then pushed the DPI back down to 4600 and everything felt normal again.

I believe this is a random bug with windows just randomly bugging out? Cause I've used the Razer naga on an old razer goliathus control mouse pad which is mostly black with some green on it and my laser and optical mouse didn't have an issue with it and I've now had this razer goliathus speed extended edition mouse mat for about a month now which is mostly green with shades of black here and there that and in razer synapse my mouse is specifically calibrated for this mouse pad.

If it was a problem with the mouse mat then there would be a lot of people complaining that these mouse mats are bad but they aren't, specially since this mouse is designed to operate on almost any surface even a towel even my old cmstorm devastator optical mouse could do it.

Aside from that when the issue occurred I noticed my Logitech orion spark G910 keyboard started to act up too all the leds turned off then back on for a brief few seconds however the Logitech gaming software or Razer synapse programs (controls features of Logitech and Razer devices) didn't report any malfunctions or errors, and couldn't be that that software restarted as when Logitech gaming software isn't running the leds default to cyan blue colour rather then the colour I set.

As a technician this entire ordeal is bizarre been around pcs since I was 5 for 21 years and this is the first time I've seen this happen. I've had dust and hair in the mouse before but they don't act like this and for that to cause the mouse sensitivity settings to reset to default in control panel is unheard of.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.