Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently begun hosting my personal website under a home server using dynamic dns.

The domain is registered under Godaddy, and ZoneEdit as the dynamic dns manager. Everything works well till it reaches my router (with Tomato v1.28). The domain (lets say example.com) translates as follows:

http://www.example.com ---> http://192.168.1.200/wiki/index.php/Main_Page

instead of

http://www.example.com/wiki/index.php/Main_Page

I'm using the in built port forwarding feature in Tomato. The above ofcourse works on a machine connected to the local network.

This happens only when attempting to access the root url i.e. www.example.com, but www.example.com/blog or www.example.com/wiki retain the domain name.

I'm using a centos server, with apache.

share|improve this question
    
The problem wasn't in either the router or in setting the hostname, but in the LocalSettings.php of mediawiki I'm using. Fixing the servername in the file fixed everything. –  Praveen Oct 25 '12 at 15:19

2 Answers 2

Your webserver is redirecting but has not been configured with a DNS name so uses it's internal IP_address in the redirection response.

Configure the domain name in the webserver software.

share|improve this answer

That has got nothing to do with your router. You need to add your domain name to the web-server. If you are using apache, then you may have to add your domain name to the vhosts file. Read more here: http://support.aiso.net/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=243

share|improve this answer
    
I have configured my hosts file, host and apache conf file, but the problem keeps recurring. –  Praveen Oct 15 '12 at 7:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.