Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a virtual machine which is currently using a folder on the C: drive to store its snapshots. I have copied the contents of the "Snapshots" folder to an alternate drive, but whenever I go into the General / Advanced settings section for that virtual machine and change the snapshot folder to the new location it resets back to the original location. What do I need to do to get VirtualBox to recognize the new location for the snapshot files?

share|improve this question
If you can change the value to something else, but your changes are reset without any reasonable cause, maybe this should be reported as a bug: – Oliver Salzburg Oct 12 '12 at 15:03
That's the thing... I don't know if there is a "reasonable cause" (e.g. I need some permission that I don't have), or if it should just work. Thanks for the suggestion though. I may file a bug report anyway. Worst case scenario they just close it "operating as designed". :-) – Richard J Foster Oct 12 '12 at 15:14

If you already have snapshots I think you'll have to do what I did, which is manually edit the .vbox xml file. This is what I did for a Win7 32 virtual machine named Win7_32

  1. Shut down the VirtualBox Manager
  2. Navigate to the user/VirtualBox VMs/Win7_32/Win7_32.vbox
  3. Make a copy of the .vbox file just to be safe.
  4. Open the original file with a text or xml editor
  5. Look for a "currentSnapshot" entry.
  6. Manually enter the path to your new snapshot folder
  7. Scroll down a little and look for the HardDisks entry. You should see an entry for your base hard disk, you don't have to change this.
  8. You should also see entries for all your snapshots. You want to modify the "location" attribute so that it reflects your new desired Snapshot path
  9. Save the changes to the file
  10. Move all your old snapshots to the new path
  11. Start the virtualbox manager and start your machine
share|improve this answer

As of Virtual Box 4.2 onwards (so for quite a while now, since VBox 5 ist current) there is a setting under [Machine]➝General section➝Advanced tab: Snapshot Folder.

It's greyed out while running. Shut down the vm to change it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.