Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I looked at this post and it seemed to be close to what I want, but my case might be a little worse:

How can I reset my windows 7 file permissions to a rational state?

Basically a while back I (very stupidly) changed the permissions on all sorts of system folders, and eventually rendered my computer virtually unusable. I managed to hack administrator privileges back onto key folders and get it working, but in doing so I only modified permissions a lot more away from the natural state. I'm looking at this icacls stuff, but ultimately I need to reset EVERYTHING back to what it was in The Beginning, before I messed with it, from the C: directory all the way down. Right now application data is what's giving me problems, and I can't get it to work no matter how much I fiddle with those specific permissions.

I will be forever grateful for help on how to do this without having to reformat.

Update: I've found that it's in an odd position where I may have set the permissions for something more or less correctly, but any and all automated actions (like running batch operations from an elevated command line or trying to apply changes to subfolders) will still tell me "access denied." However if I manually navigate to those folders and simply try to open them, Windows tells me that access is denied, but that by clicking "ok" I can permanently give myself access to it, and that fixes problems. This is great except in order to fix this I have to manually open every folder affected, and there doesn't seem to be any pattern to it. How can I fix this!?

Further update: This question has gotten a lot of views but very little activity. I eventually gave up and reinstalled Windows.

share|improve this question
Related but not completely a duplicate:… – Canadian Luke Oct 12 '12 at 14:58
At this point I suspect that the only way to get everything back to being right would be to reimage. – EBGreen Oct 12 '12 at 15:16
I'm starting to think that's true. I've been trying solutions posted elsewhere and now I can't open Chrome without running it as administrator. – ssb Oct 14 '12 at 14:57

Running this command at an elevated command prompt should get you back to a usable state.

secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

Source: Even though this article is for Vista, it works for Windows 7 too - How do I restore security settings to a known working state?

share|improve this answer
The problem is that when I try this I get an error, and in the log it just says this a bunch of times: Warning 5: Access is denied. Error setting security on machine\software\microsoft\windows\currentversion. So you can see my dilemma. – ssb Oct 12 '12 at 15:29
You're certain you are running the command prompt as administrator? Have you tried to log in as administrator in Safe Mode? Or boot to Windows Recovery Console? All worth a try before reformatting. – CharlieRB Oct 12 '12 at 15:35
Yes, the "administrator" in the title of the command prompt is evidence enough of that. I have tried the admin account but for some reason I still get access denied when trying to change certain permissions. – ssb Oct 12 '12 at 15:37
Did you by chance try a System Restore back to a date prior to the changes you made? – CharlieRB Oct 12 '12 at 15:42
I've upvoted but reverted it because the linked article explicitly states: The use of “secedit /configure” to import the default security template, dfltbase.inf, is unsupported nor is it a viable method to restore default security permissions on Windows Vista, Windows 7, Windows Server 2008 and Windows Server 2008 R2 computers. – wmz Oct 14 '12 at 15:53

I have a folder titled "Everything" that contains EVERYTHING I have created. So as usual, I decided to be the "genius" I am, I tried attempted to change permissions to prevent my Admin from reading, writing, or modifying/deleting or adding anything. In the process, I locked myself out of the folder. Here are the steps that your'e gonna want to take:

  • right click the folder/item, and click properties
  • go to the security tab, and then click on advanced
  • Select change permissions, and then "edit"
  • You will see a few of the users on your PC listed, and select the one that says "Home User", then click allow for all of them
  • click 'Ok' and then apply the settings

This should help your problem! If it doesn't, I'm sorry. I'd recommend just playing around with the different settings and stuff. I hope this helps!

share|improve this answer

use Permissions Time Machine v1.2 to restore permissions to folder or files or registry keys download it from amyd projects blog

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .