Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to run this command:

emerge -avuDN world

I get this message:

WARNING: One or more updates have been skipped due to a dependency conflict:


  (media-libs/freetype-2.4.10-r1::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/freetype-2.2.1[lcdfilter] required by (media-libs/fontconfig-2.9.0::lcd-filtering, ebuild scheduled for merge)

How should I resolve this dependency conflict?

I've already tried to reinstall fontconfig and freetype, I've even set the ~x86 for them in /etc/portage/package.keywords.

I'm kind of lost, and already tried Googling. Can anybody help me?

Portage version:

Portage (default/linux/x86/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.6.1-gentoo i686)

Linux kernel:

Linux genta 3.6.1-gentoo #1 SMP Thu Oct 11 19:52:23 NOVT 2012 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz GenuineIntel GNU/Linux

Will be glad to provide any logs or configs ASAP.

share|improve this question
Would be there any suggestions? Maybe I should look into some specific forums? – user157378 Oct 14 '12 at 13:35
up vote 1 down vote accepted

You have to mask freetype >= 2.2.1


emerge -C fontconfig-2.9.0
share|improve this answer
Thank you! Actually the problem got solved by itself... One day I've launched emerge --sync && emerge -avuDN world, and the freetype warning has gone! – user157378 Oct 29 '12 at 19:08

You must log in to answer this question.