Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run a web service that usually listens on port 8080, but there's another service on my computer that is currently listening on that port. (the process now appears to be using port 8081)

After a little bit of research, I was able to determine that the ntoskrnl.exe process was listening on that port.

It has only been using that port for the last 2 weeks, so somethin'gs changed

Can anyone help me figure out why it's using that port?

share|improve this question

2 Answers 2

Check if you have IIS installed. Turn it off if its on and then check port 8080. I know ntoskrnl.exe runs if IIS is installed.

To change the port for IIS:

  • In Start menu Search option, type: IIS and click Internet Information Services Manager or simply do a run command: inetmgr .

  • Under Connections, You’ll see your PC name click on it to expand the list. Now you can see “Sites” click on it to expand.

  • Under Sites you can see Default Web Site, right click on it and Select EDIT BINDINGS. Edit HTTP binding port from 80 to 81.

  • Open your browser and type: //localhost:81/.

share|improve this answer
up vote 2 down vote accepted

The culprit was RavenDB which was installed along the NServiceBus package.

I found the solution on this NServiceBus related group

basically typing the following into the command line.

C:\Program Files\NServiceBus.Persistence\Raven.Server.exe /uninstall

Thank you to David Murray for the Open your browser and type: //localhost:81/ remark.

I typed localhost:8080 into my browser and it brought me to a raven-DB page, which started me on the right track.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.