Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's what's happening.

I havent been using hardware RAID on my motherboard, but since I got new disks today I changed from normal SATA to RAID and rebooted.

I set up the RAID, three disks, one of them for the OS, the two other RAIDED as one. Rebooted.

The Windows Server 2003 loading-logo shows up for a second and then, it hasn't even faded in completely, I get a blue screen, which lasts for 0.5 sec and then the computer auto-reboots and does the same thing again forever.

I thought this RAID stuff should be handled automatically by the hardware but seems like WinServer2003 is missing somehing.

If I change back to not using RAID but normal SATA mode I can boot back into the OS again.

What the hell should I do to not get the BSOD??

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You need to set the registry values accordingly. See http://support.microsoft.com/kb/922976#method1 for detail. Essentially, the 'Start' values for

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

and

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV

should be set to 0.

Registry Value

Use caution when changing registry values as an incorrect setting could cause further problems.

share|improve this answer
    
Thanks, looks very promising! Will try this now. –  Nils Oct 12 '12 at 23:44
    
Neither of those two keys (Msahci or IastorV) exists. Do I can't do it. –  Nils Oct 12 '12 at 23:56
    
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci is the registry folder. The key is Start. –  Mike Oct 12 '12 at 23:58
    
Yes, sorry, I meant none of those two folders exists. –  Nils Oct 13 '12 at 0:00
    
I think I'll just try software RAID then... since it doesn't work and RAID0 with software should be almost as good as RAID0 with hardware. –  Nils Oct 13 '12 at 0:02
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.