Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

An Eclipse project can normally be renamed by a right click on the project folder and "Rename...". Every time I try this I get the message "Resource 'Project' is out of sync with file system". I get this message even if I do a refresh using F5. What could be the mistake here? Are there other ways than an export and import to rename the project?

share|improve this question
up vote 2 down vote accepted

You can export a project by clicking on

  • then import this same project with
  • .
    If you edit your files a lot outside Eclipse, enable auto-refresh with
  • WINDOWS->PREFERENCES then in the dialog box that appears, click on GENERAL->WORKSPACE and click REFRESH AUTOMATICALLY
  • share|improve this answer
    Thank you for the hint with refresh automatically. Even if I do this, I get the error... damn! – strauberry Oct 13 '12 at 7:47
    That should have helped because thats what people are saying on the internet. Try exporting and importing the same project. Thats your best bet :) – Fasih Khatib Oct 13 '12 at 8:10
    I found the error while exporting the project ^^ I had a broken symlink within my project, now it works. – strauberry Oct 13 '12 at 8:27

    You need to get your Eclipse project back in sync with the filesystem.

    Just click on your project and press F5 ("Sync with Filesystem") and then try again to rename it.

    share|improve this answer
    That's what I do and it does not work (see my edit) – strauberry Oct 13 '12 at 7:46
    +1 worked for me, thanks! – Math Aug 2 '13 at 20:27
    Thanks. It works. – mukesh Feb 26 '15 at 17:39

    When you open an Eclipse workspace from within a clearcase view and try to rename the project, you will often get the pop-up warning ... “Resource ‘project’ is out of sync with the file system”. If refreshing the project does not fix the problem, then do the following workaround: a. Open workspace WITHOUT being in a view b. Select the project in Project Explorer c. ClearCase -> Associate Project (project should now look like project [] ) d. Right click project -> Refresh (vob sub-folders should now be empty) e. Right click project -> Rename ... f. Enter New name

    Now you can close the workspace, reopen it in a view and refresh the project. You may also dissociate the project if you prefer the project not to be associated with the vob.

    share|improve this answer

    Your Answer


    By posting your answer, you agree to the privacy policy and terms of service.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.