Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using VMWare Workstation 9.0.0 build-812388, on a Windows 7 Home Premium 64-bit SP1 host.

I am trying to connect my USB Wi-Fi Adapter (Atheros UB91C) and connect it directly to the guest OS (Also Windows 7). When I attempt to do so, VMWare gives me the error:

The connection for the USB device 'Atheros UB91C' was unsuccessful:
    The device is currently in use.

So far, I have attempted to uninstall the adapter, which led to a driver error. Afterwards, I re-installed the adapter drivers and disabled it. I still get the same message.

My USB controller for the virtual machine is present and set to USB 2.0 compatibility. The Wi-Fi dongle is connected to the USB 3.0 port, but the same problem happens even when I use the USB 2.0 port.

Searching online only gave me links that talked about USB 3.0 incompatibility with workstation 7.1 or below, but I've read that Workstation 9 supports USB 3.0.

Do you know why my VMWare Workstation USB Wifi is still in use?

share|improve this question

migrated from stackoverflow.com Oct 13 '12 at 13:04

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I have the exact same problem with an Asus A55V running Windows 7 Home Premium 64-bit. The cause seems to be VMware's lack of support for Intel USB 3.0 drivers. You may find that no USB devices work at all in the VM, not even flash drives. I have tried both VMWare Player and Workstation, to no avail.

One suggested workaround is to uninstall the Intel USB 3.0 drivers. But this had the effect of knocking out all the USB ports on my notebook, even in Windows. Another suggestion is to reinstall Windows but not install any vendor-provided or Intel drivers. Just allow Windows to recognise the USB ports during setup and install its own drivers. I have not tried this yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.