Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Internet Explorer 10 on Windows 8 RTM and just saw, that IE suggest some sites when entering something in the address bar. That wouldn't surprise me at all, if I had ever visited these sites, but I haven't. To ensure that no ads have injected these sites into my browsing history, I've deleted my history and cookies without preserving my favourite website data. I also double checked that suggested sites feature is turned off. But even after cleaning my history these sites show up.

Now I'm little concerned what is causing this. Did Microsoft add these sites by default to make some money (all these sites are commercial) or do I already got some nasty adware?

Edit: Search suggestion are disabled too.

sites IE suggests when typing a in the address bar

share|improve this question
2  
Just checked my W8 IE10, does the same thing. I got AOL, Amazon and AT&T and I have not visited any of these sites, its advertising, jerks. –  Moab Oct 13 '12 at 19:41
    
Thanks for confirming this. I hate W8 more and more. –  Jay Oct 13 '12 at 19:45

1 Answer 1

up vote 6 down vote accepted

They are called "Search Suggestions", depending on what search provider you have chosen for IE10 what it will return, you should be able to turn off search suggestions for your default search provider in add-ons. I tried disabling everything for Bing my default search provider and it does not change anything, it still suggests, so I assume it is broken or is not suggested sites causing this behavior.

enter image description here

.

Maybe it is not suggested sites, doing the following disables that behavior,

Internet Options > Content Tab > AutoComplete settings

uncheck "Suggesting URL's" box.

Even though I have NEVER visited anything it shows me, its SPAM from Microsoft.

Note: You must disable autocomplete (suggesting URLs) and suggestions for your default search provider to stop all suggestions in the URL bar. I disabled auto complete and turned on suggestions for my Google default search provider and the suggestions changed to something else, so the autocomplete setting overrides the add-on setting regardless of which provider you use, this has to be a bug or worse Microsoft being really bad, say it ain't so!

.

enter image description here

share|improve this answer
    
I've already disabled search suggestions. Forgot to mention it. Thanks anyway. –  Jay Oct 13 '12 at 19:47
    
@Jay check my edit. –  Moab Oct 13 '12 at 20:09
    
Thanks, that did the trick. –  Jay Oct 13 '12 at 21:51
    
What tool did you use to make those nice red pointers in the images? –  David Jun 28 '13 at 15:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.