Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My daughter seems to have fried her motherboard in her Lenovo Notebook. The disk seems to be fine. I removed the disk and used a universal disk-to-USB kit to attach it to another computer. The disk is recognized fine and I can peruse it in Windows Explorer. The problem is that the files she would like to recover from it are located in places that Windows refuses to let me access. When I try, for example, to enter the directory "Documents and Settings" it gives me an "Access is denied" error. Same thing when I try to go into the various User directories and other locations.

I thought to try creating a Ghost image & retrieve the files from that, but Ghost seems to croak when I try to run it - apparently it doesn't like accessing the disk via a USB connection (even though I've told it to install the drivers for USB).

Any other ideas about how to get to the files I need, either through Windows or perhaps some other OS that I could boot from a CD that can read an NTFS disk? Thanks, Yosh

share|improve this question
1  
This is for XP but will work for all versions of Windows, see "How to take ownership of a folder" section...support.microsoft.com/kb/308421 –  Moab Oct 13 '12 at 21:06
    
Thanks - that looks like it might solve the problem. While researching your lead, I came across this tool: neowin.net/forum/topic/936972-ownership-changer - looks like it might be a simpler way to do the same thing & works on Win7 (according to the description). If I have anything more to report after trying it, I'll add a comment. Thanks! –  yosh m Oct 15 '12 at 7:33
add comment

2 Answers

Firstly, you can try to take ownership of the folder with windows itself. You must be an administrator for this to work! So, here goes.

  1. Right-click on the folder and click on "Properties"
  2. Go to the "Security" tab.
  3. Click on the "Edit..." button
    1. Click on "Add..." and enter your username in the textbox
    2. Click on "Check Names", just to be on the safe side, and then click on "OK". Your account has appeared in the list of users.
    3. Click on your account and then select the necessary permissions (basically: select "Full control")
    4. Tada! That's done. You might have to repeat this process for other folders. If this doesn't work, please follow the next set of steps.
  4. Instead of clicking on "Edit...", click on "Advanced" in the properties window.
    1. Click on "Change" next to "Owner:" at the top.
    2. Enter your username, click on "Check Names" and then on "OK".
    3. Select "Replace all child object permissions (...)" and click on "OK" again. And again... Tadah
  5. If this also didn't work, click on "Add" instead of "Change" (step 4.1).
    1. Click on "Select a principal", enter your username, etc...
    2. Select "Full control".
    3. Select "This folder, subfolders and files" next to "Applies to:"
    4. Click on "OK", "OK", "OK"...
  6. This is all you can do with Windows itself.

You might want to use a 3rd-party program for some reason.

For this, please follow the instructions here: Add "Take Ownership" to Explorer Right-Click Menu in Win 7,8 or Vista - How-To Geek. After installing the mentioned tool, right-click on the folder and select "Take Ownership" as shown on the picture below:

"Take Ownership" context menu item

Or you can use the program you mentioned yourself: Ownership Changer - Software created by our members - Neowin Forums

As a 'last resort', you can use a LiveCD of a Linux distro (Ubuntu, for example) to copy the files from the external HDD.

Or you can use GParted (yes, its main purpose is managing partitions, but as you can see here, (other) manipulation of hard drives is also possible)

btw, I assume you mean the "Users" folder? "Documents and Settings" isn't used anymore since Windows Vista. Well, nevermind, doesn matter.

share|improve this answer
    
Thanks - that's a lot of useful leads. I actually dealt with the immediate problem I had back then, but this information will likely help the next person who has the same problem - thanks for the info & effort. –  yosh m Apr 16 at 21:37
    
You (and all others facing this problem)'re welcome. I'm happy to help! –  nidunc Apr 16 at 21:39
add comment

OK, first of all, make sure you are able to access the correct directories. In Windows 7, in my user directory C:\users\[username]\, I see two "My Documents" but one is like a symlink or something and doesn't let even me "open" it. My Documents - 2 of them (screenshot) In the above screenshot, the selected "My Documents" is the directory that lets me get to all my files. The second one (with the shortcut symbol on it) doesn't seem to work for even me. So make sure you're trying to get to the right directory.

Also, a modern Linux distro can access NTFS and iirc, will ignore NTFS permissions and allow you to copy files off as necessary.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.