Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set JAVA_HOME and put JAVA_HOME/bin to PATH variable.

But Internet Explorer still doesn't support Java applets. Why?

share|improve this question

1 Answer 1

See How do I enable Java in my web browser?

Internet Explorer

  1. Click Tools (Alt+X) / Internet Options

  2. Select Security tab / Custom Level button

  3. Scroll down to Scripting of Java applets and make sure the Enable radio button is checked

  4. Click OK to save your preference

Chrome

  1. Click on Wrench icon / Options`

  2. Select Under the Hood / Privacy Content Settings (the Content Settings panel will appear)

  3. In the Plug-ins section, select the Disable individual plug-ins link to check whether Java is enabled

  4. Click on the Enable link (if the Disable link appears, Java is already enabled)

share|improve this answer
    
that was no such option ... in fact i don't install jdk, but extract one jdk from zip file –  hugemeow Oct 14 '12 at 2:15
    
For IE to display applets, you need the Java plugin installed which comes with the JRE. If you have some sort of portable install, it's probably not gonna work in IE (you can use the appletviewer though). Also, you should have mentioned your non-standard setup details in the question. –  Karan Oct 14 '12 at 2:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.