Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Aperture library that I've been using for several years.

In the past week a number of recent photos and movies have mysteriously disappeared.

The missing files were all safely imported within the last week (I had reviewed some of the movies within Aperture, so know this to be true). The files were all referenced on an external drive.

Within Aperture the files now have a "referenced file can't be found" icon.

I've tried searching for the missing files manually, including within the Aperture library package, but they cannot be found anywhere.

How can I (a) work out where the missing files have gone, and (b) identify the cause and ensure it doesn't happen again?

I'm using Aperture 3.3.2.

share|improve this question
add comment

1 Answer

Sounds like the files are still on the external drive, but the referencing broke. Make sure the drive is mounted.

(a) Try selecting one of the "referenced file can't be found" images, and using "File > Locate referenced files" as described here. Navigate to your mounted external drive and find the image in question. The command should be able to work out multiple references based on one manual selection.

(b) Don't know yet!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.