Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I read lot of posts related with blocking sites. Most of the posts says to edit hosts file. I know it is a good method. But this one is not working for me.

Can you guess what is the issue by analyzing the following details,

My PC is joined to a domain and using proxy settings, and the logged in user having administrator privileges.

After reading some answers, I did the following

Changed the hosts file to have

#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
127.0.0.1   www.facebook.com

Added no proxy for facebook, enter image description here

Still, it is not working. Why ?

share|improve this question
up vote 4 down vote accepted

Hosts file won't work when using a proxy, as dns lookup is done on the proxy. You might manage to exclude the site from being proxied in browser settings and then use the hosts file.

This does sound a bit backwards though - the proxy is the place to do this.

share|improve this answer
    
Can you please see the updated question ? – Rauf Oct 14 '12 at 13:45
1  
Suggest you put "www.facebook." in the do-not-proxy, though IE is notoriously bad at obeying these, make sure you restart the browser. – Tom Newton Oct 14 '12 at 14:10
    
You really are on a sticky wicket here BTW - why is it you can't do this at the proxy, or worst case put in an intermediate proxy? – Tom Newton Oct 14 '12 at 14:11
1  
yes. Its OK when I write www.facebook.com – Rauf Oct 14 '12 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .