Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a mic plugged into my computer, and I was able to use the "microphone effects" tab here to enable/disable noise suppression and acoustic echo cancellation.

Noise suppression off and acoustic echo cancellation on were the most recent settings I had on before the problem occurred. I disabled my mic in the windows 7 "recording devices" tab, then re-enabled it. When it came back, these options were grayed out, and remained so even after a reboot.

I am not sure why this is or how to fix it, all other options are still the same (Settings are identical to when it was working). Any ideas whats wrong or how to fix it?

edit: can't post image due to being new.

share|improve this question

2 Answers 2

Since it was so hard to come by a solution and this still has not been answered, I decided to drop my solution here.

The microphone effects seem to depend on rather low recording quality. I changed from studio quality down to DVD quality within Realtek HD Manager and the options became available once more. The only downside of course is that your voice will sound rather bad compared to the previous higher quality.

share|improve this answer

I discovered the same solution as 3ventic. Specifically, when I had the default format for the microphone in Realtek HD Audio Manager set to "16 bits, 96000 Hz (Studio Quality)", none of the special options were available, but upon switching it to "16 bits, 48000 Hz (DVD Quality)" the options became available again.

You can also change this setting by going to (in Windows 7): Control Panel > Hardware and Sound > Sound > Manage audio devices. Select your microphone device in the Recording tab, right click and select "Properties". In the window that pops up, go to the "Advanced" tab and select an appropriately low quality setting, click "Apply", and you should be good to go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.