Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a privileged user without home folder with ssh access. I try to do X forwarding but I get the message /usr/bin/xauth: error in locking authority file /home/user/.Xauthority If I don't have home folder logically .Xauthority doesn't exist. Is there a way to replace the location or tell xauth to use a different file?

share|improve this question
    
If the user is privileged, use it to create the home directory. – grawity Oct 14 '12 at 15:59
up vote 2 down vote accepted

You can change the location of this file by setting the XAUTHORITY environment variable.

$ export XAUTHORITY=/tmp/.Xauthority_$USER
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .