Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I mount an external drive with read/write permissions for my user name?

I have tried mounting the drive in both /mnt and ~/mnt through fstab, but neither gives wdkrnls write priviledge.

fstab:

LABEL=500-hitachi /home/wdkrnls/mnt/500-hitachi ext4 defaults,users 0 1

How the drive is being mounted in my home directory via ls -lah:

total 24K
drwxr-xr-x 3 root     root  4.0K Oct  8 20:46 .
drwxr-xr-x 3 wdkrnls  users 4.0K Oct 14 14:14 ..
drwx------ 2 root     root   16K Oct  8 20:46 lost+found
share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

With the ext4 filesystem, permissions do not depend on mount options. (Although there was a proposed patch for that, but it was rejected.) You will have to use chown and/or chmod to give yourself write permissions.

share|improve this answer
add comment

In addition to grawity's informative answer, you can use the pmount utility from extra to easily mount devices with rw permissions as a normal user.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.