Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have openjdk and jRuby installed and running properly.

however when i run exactly same environment under chroot, i get:

error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory

i can see the libs, they are in place.

played with setting PATH, JAVA_HOME and LD_LIBRARY_PATH to correct values.

did not help.

any clues?

share|improve this question
up vote 3 down vote accepted

seems you did not mount proc under your chroot.

try to mount its own proc by:

# inside chroot
mount -t proc none /proc

or to "share" system's proc by:

# outside chroot
mount -o bind /proc /path/to/chroot/proc
share|improve this answer
    
worked! thank you much – Dani El Oct 14 '12 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .