Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Google Chrome, by default, blocks insecure content on secure pages. Is there any way to allow it to load the full content and have it ask me (like Firefox does)? Even if it doesn't ask me and just loads it that is OK with me.

share|improve this question
up vote 48 down vote accepted

When you visit a secure page with insecure content, a shield icon will appear at the right edge of the omnibar.

Click on the shield icon, and then click Load anyway, and the insecure content will be loaded.

enter image description here

share|improve this answer
    
Works for me in chrome 30.0.1599.66 – Mike Nov 14 '13 at 2:44
    
doesn't work here either: there is no shield despite the message stating that I should allow safe content, this is to connect to google docs hosted at my university, strange, doesn't work on chrome/firefox , but does work on safari... – PatrickT Nov 29 '13 at 6:23
1  
@PatrickT That may have to do with the way your university has configured its servers. It is possible for a HTTPS server to specify, for instance, strict transport security, in which case insecure content would never be loaded. – Michael Hampton Nov 29 '13 at 6:25
    
I see thanks Michael. Yes, I suspect our IT have messed up, wouldn't be the first time ... The page has the message In your address bar > click a small icon > select load unsafe script in the message > done > refresh the web page. but no icon ... Never mind, I can use Safari. Note to others: try Safari, perhaps a workaround. Thanks! – PatrickT Nov 29 '13 at 6:36
    
Just a fyi for future finders, this is currently broken in Chrome 34. code.google.com/p/chromium/issues/detail?id=333308 – Joshua Dance Apr 10 '14 at 22:22

Michael Hampton's answer requires that you click twice to load insecure content - if you want this to happen automatically, then there's a command line switch which disables this warning.

Start Chrome with the switch

--allow-running-insecure-content

or add this to Chrome's shortcut like so:

..\application\chrome.exe --allow-running-insecure-content"

and it will load insecure content automatically.

Note: I don't approve that you do this, but you have asked for this, hence I'm providing you with a way to do it

share|improve this answer
1  
Is there any way to do this without using a command line input, so I can do it for a single website? – Sponge Bob Oct 15 '12 at 5:31
    
@KeeganMcCarthy no, not to my knowledge – Sathya Oct 15 '12 at 5:33
2  
@KeeganMcCarthy The permanent answer is to fix the offending website. – Michael Hampton Oct 15 '12 at 14:42
    
@MichaelHampton Indeed. It is my school's "moodle" site that has the problem, however, the solution is not so easy. – Sponge Bob Oct 15 '12 at 16:06
1  
@YumYumYum the flag is still around, so it should work peter.sh/experiments/chromium-command-line-switches/… – Sathya Dec 2 '15 at 4:20

on a mac, you can create an applescript application in applesript editor with following contents:

do shell script "'/Applications/Google Chrome.app/Contents/MacOS/Google Chrome' --allow-running-insecure-content > /dev/null 2>&1 &"

when you save it as an application, you can assign chrome icon to it :)

share|improve this answer
    
how does this work? – PatrickT Nov 29 '13 at 6:34
    
@PatrickT this launches Chrome with the command line flag to run the unsafe content. If it doesn't make sense, try a different solution since always loading unsafe content can literally be unsafe. – Joshua Dance Apr 10 '14 at 22:23
    
simple and works for me! I needed this to make LiveReload work with localhost-https app – Larry Gerndt Aug 7 '14 at 21:58
    
Version 47. this is not working anymore. please test and update the answer kindly. i tested myself and it failed in OSX also in Windows 8. – YumYumYum Dec 1 '15 at 23:40

A simpler approach is to create a dedicated insecure instance via a shortcut with "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --allow-running-insecure-content. This way you don't have to be annoyed on allowing all the time in your browser and can run a separate instance at the same time as a regular instance of Chrome while working within a site. Check out the tutorial at: http://www.1337admin.org/windows/windows-7/allow-chrome-to-load-insecure-content/

share|improve this answer
    
Although this may answer the question, you should give a more detailed description of the linked content and explain how it relates to the question. This will help ensure that this answer remains useful in the event the linked page is removed or goes offline. For more information, see this Meta Stack Exchange post. – bwDraco Oct 7 '15 at 21:55

Windows 8:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --allow-running-insecure-content

OSX 10.11:

'/Applications/Google Chrome.app/Contents/MacOS/Google Chrome' --allow-running-insecure-content

share|improve this answer

protected by Community Nov 22 '13 at 17:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.