Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I read this post on superuser on how to view UTF-8 characters on command prompt in windows. I tried the steps in the answer which were :

  1. Start -> Run -> regedit
  2. Go to [HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\Autorun]
  3. Change the value to chcp 65001

I reach Command Processor but then I do not see Autorun .
I have added a screenshot of that :

enter image description here

What do I do now ? The font I have selected for cmd is Lucida Console. I want to see the Unicode characters on the command prompt. Like I have to test some programs that contains Urdu text. I get question marks or some other sort of text in place of the original one.

Note: I am using a 32-bit OS

share|improve this question
    
Check Jukka's answer below, then if the chcp command and selected font works from the command-line, try adding the Autorun sub-key and then modifying its value. – Karan Oct 15 '12 at 5:01

The accepted answer you quoted has an error: the code page number for UTF-8 in Windows is 65001, not 6500. You should test things first by just setting chcp 65001 in the console window; the question cited is just about making this setting the default by making Windows execute it automatically.

To see Urdu text, you need to select a font that contains the Arabic letters used in Urdu. Lucida Console does not contain Arabic letters. I would expect that checking for font support to the letter PEH is suitable. Among the alternatives that are commonly available, Courier New is the only monospace font – but Arabic writing isn’t that suitable for monospace rendering, so consider using e.g. Arial, unless you have a special reason to use a monospace font.

share|improve this answer
    
Just edited the other post, wonder how come no one caught the error till now! – Karan Oct 15 '12 at 5:00
    
Also noticed that command-line on my windows 7 64 bit doesn't require autorun to have unicode, I see unicode characters right after selecting Lucida Console as the font. So probably just Arabic support is the only problem – Maksee Oct 15 '12 at 5:10

There is a better answer on same page by Steven Penny:

REG ADD HKCU\Console /v CodePage /t REG_DWORD /d 0xfde9

just execute above code from anywhere in windows(for example in cmd or in run) just for one time and your code-page on cmd will be changed to 65001 forever.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .