Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem where Ubuntu is shutting down immediately after restarting from Hibernate. I want to boot without Hibernating. Can I use grub options/commands to set it to ignore the Hibernate image for the next boot?

share|improve this question
up vote 5 down vote accepted

The kernel will ignore the resume partition used to restart from hibernate if you pass it the 'noresume' option at boot. Pass this as a kernel option at the grub bootloader. See here and here.

For a more permanent solution, you can append this option to your default boot image so it never looks to resume from a hibernate image.

share|improve this answer

I tried the noresume option. I'm not sure if I actually used it correctly but the boot behaviour was different. This allowed me to do an CTRL-ALT-F2, get a terminal, login and shutdown.

A colourful menu appeared and I selected boot. I booted and then restarted again from login screen.

All seems OK now.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .