Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem with Windows 7 x64 consistently disconnecting one specific USB mass storage drive immediately after it is connected. The drive in question is a Cowon C2 digital music player which works both in MSC (mass storage controller) or MTP (Media Transfer Protocol) modes, i.e. there are no device-specific drivers needed/available. The basic issue is the same in both MSC and MTP modes.

When I connect the player, Windows plays the "USB connect" sound and the device appears (under its correct name) in the device manager, but it never appears as a drive. The player itself displays "USB Connected" for a split-second before reporting that it has been disconnected again. Since the player, by design, reboots after it has been disconnected, Windows plays the "USB disconnect" sound before restarting the whole cycle once the player has powered back on.

I am connecting the player through an Intel X79 Chipset motherboard (Gigabyte GA-X79-UD3) to Windows 7 Pro 64-bit. The player used to work fine the first time I connected it in MSC mode, showing up as an external drive; the issue only appears when subsequently connecting it again. This can be reproduced: uninstalling the standard Windows mass storage driver (USBSTOR.SYS) from the device manager while the device is visible there, then reconnecting the device, the driver is automatically reinstalled and the device remains visible. After disconnecting and reconnecting it, the problem occurs once more. In MTP mode, driver installation fails in the first place, but that might be due to other reasons. The problem is the same: as soon as the device is connected to the computer, Windows disconnects it again.

It is not a problem with the player, since the issue does not occur on another system running the exact same operating system. It is also not a problem with the USB controller, since the issue is the same on both the Intel USB 2.0 and the Fresco Logic FL1009 USB 3.0 controller ports. I have also not had the problem with any other drive so far.

Among the things I have tried so far:

  • Disabling USB legacy mode in BIOS
  • Disabling energy-saving power down for all USB controllers in Windows' device manager
  • Removing and reinstalling USB controller drivers
  • Restoring the player to factory defaults

None of these made a difference. I would be very grateful for any hints on what else to try.

Edit: Here is another new hint; I found out that when I connect the drive before booting Windows, it is available in Windows Explorer as it should, and does not automatically disconnect. If I remove and reconnect it though, the infinite connect/disconnect-loop starts anew.

share|improve this question

1 Answer 1

It looks like the driver was messed with by something. What you should do is try and install the official drivers from the manufacturer's website. If you want to check if it is a hardware issue, consider testing it with an ubuntu LiveCD

Other things to try:

  1. Start into safe mode: KB Article
  2. Try automated registry repairs: Advanced SystemCare
  3. All out system restore (BACKUP!!): Guide
share|improve this answer
    
As stated in my question, there is no driver, the device works as a standard USB mass storage device. And as also stated, it is not a hardware issue since the device connects fine to other Windows 7 systems. –  Daniel Saner Oct 15 '12 at 22:58
    
Sorry, by hardware I meant on the motherboard, or maybe it could just be windows 7... You should give the livecd a shot because that will confirm if it is windows or the board. –  Wijagels Oct 15 '12 at 23:08
    
By your most recent edit it looks more like your copy of windows 7 may have been dropped on it's head. –  Wijagels Oct 15 '12 at 23:09
    
Works on a Live Ubuntu, as expected since it also works on different Win7 systems. Rather than Windows 7 itself I am suspecting some other application or driver interfering. I would sure love to know a way to check that... I have changed absolutely nothing, hardware or software, between now and back when it used to work. –  Daniel Saner Oct 15 '12 at 23:16
1  
Have you tried a system restore? (Make backups first!!!) Certain applications, ahem, microsoft, tend to do background things that can sometimes make a mistake and mess with things. Sometimes registry cleaners such as Advanced SystemCare can fix some problems. Try out a restore only if you have the time and the backups. Good thing it's a software fault and not a hardware issue! This shouldn't cost a cent to fix. EDIT: Also try safe mode, enable startup applications 1 at a time KB: link –  Wijagels Oct 15 '12 at 23:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.