Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Cryptophane as a Windows front end for GPG.

I used it before, and all was well, until I formatted my computer - I am now trying to restore my key database.

Steps I did:

  1. Install GPGWin
  2. Install Cryptophane, pointing its homedir to my previously backed up homedir.
  3. Tried to use File-->Message (Ctrl-M) on a previously read message, and I get this dialog:

enter image description here

The secret key is required to decrypt this data, but was not found.

  1. Tried to clean the local database and start a fresh one, and then import keys from the old backup - still, the same dialog.

I see that while keys are successfully imported, the email field is left blank in the main cryptophane window for each of my rows, even though when I double-click on each record I see the email address displayed correctly.

How can I proceed to diagnose the issue/s?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
+100

I was able to recreate your problem and It appears you've encountered an incompatibility between recent versions of GPG4Win and Cryptophane. The current version of GPG4Win is 2.1.0, which combined with Cryptophane 0.7.0 (the last update was in 2009) yields the exact issues you've encountered. I tried to install GPG4Win 2.0.0, the oldest version available on the GPG4Win website, but that didn't work.

The only solution I found was to install Cryptophane from the Cryptophane 0.7.0 beta + GnuPG 1.4.2 full installer package. As the title suggests, this package includes an older version of GPG than is available through the GPG4Win website. Once installed, I was able to load my test key files and use Cryptophane as normal.

Installing Cryptophane 0.7.0 beta + GnuPG 1.4.2:

  1. Download the full installer
  2. Close any GPG related programs like Claws, Kleopatra... actually, just close everything
  3. Launch the installer, overwriting any previously installed version of Cryptophane
  4. Close Cryptophane if it opens automatically after the install
  5. Update the configuration file, cryptophane.ini in the install path:
    • Comment out the gpg-path configuration option which may have been set by a previous install
    • Make sure the homedir configuration option is commented or points to the folder containing your .gpg files (your key files). If this option is commented out, the default path is %appdata\gnupg
  6. Save your changes to the cryptophane.ini file and launch Cryptophane - you should be good to go!

Hope this helps,

Matt

share|improve this answer
    
Thanks, I'll accept you answer since it seems like you did your homework. I'll test it when I get a chance. –  ripper234 Oct 31 '12 at 8:12
    
@ripper234 - Thanks! Hope it helps. –  Matthew Johnson Oct 31 '12 at 13:24
    
And ... it works flawlessly! Thanks for the detailed instructions. –  ripper234 Nov 9 '12 at 10:31
    
@ripper234 - Glad to hear it! –  Matthew Johnson Nov 12 '12 at 14:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.