Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Telnet from my mac OSx doesn't work while it works from the AWS instances and other networks. I have no local firewalls. Nothing related in /var/log/system

In the below transcript, the telnet hangs at "Trying 74.125.136.26..." I have tried many different addresses across multiple domains.. same result !

Rocky-Balboas-MacBook-Pro:~ rocky$ 
Rocky-Balboas-MacBook-Pro:~ rocky$ dig gmail.com MX +short
30 alt3.gmail-smtp-in.l.google.com.
40 alt4.gmail-smtp-in.l.google.com.
10 alt1.gmail-smtp-in.l.google.com.
20 alt2.gmail-smtp-in.l.google.com.
5 gmail-smtp-in.l.google.com.
Rocky-Balboas-MacBook-Pro:~ rocky$ telnet alt2.gmail-smtp-in.l.google.com 25
Trying 74.125.136.26...
^C
Rocky-Balboas-MacBook-Pro:~ rocky$ telnet localhost 80
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
^C
Connection closed by foreign host.
Rocky-Balboas-MacBook-Pro:~ rocky$ 

edit: let the telnet command run and here are the results

telnet: connect to address 74.125.136.27: Operation timed out
Trying 2a00:1450:4013:c01::1a...
telnet: connect to address 2a00:1450:4013:c01::1a: No route to host
telnet: Unable to connect to remote host
share|improve this question

migrated from stackoverflow.com Oct 16 '12 at 3:43

This question came from our site for professional and enthusiast programmers.

1  
Your ISP may be blocking port 25, to prevent their customers from becoming spam zombies. –  Barmar Oct 16 '12 at 0:56
    
AWESOME !! I had this same problem 2 years back and totally forgot about it :) DO add it as an answer and I'll accept it, sure this will help many others –  Stewie Oct 16 '12 at 1:04

1 Answer 1

up vote 2 down vote accepted

Your ISP most likely blocks port 25. This is a very common anti-spam technique, to deal with customers whose computers have been infected and turns into spam zombies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.