Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 8 (final, MSDN) on my Macbook Pro Retina.

Windows 8's ongoing, continuous tantrum of insisting that it's on a tablet device is causing it to always have a touch keyboard 'icon' on the taskbar.

The 'icon' is actually a toolbar and I can temporarily disable it by right clicking the taskbar and DE-selecting it. However, upon rebooting the system, it always insists on coming back and activating itself.

Windows 8 "Touch Keyboard" toolbar icon

How can I permanently disable the touch keyboard toolbar in the taskbar?

share|improve this question
2  
Disabling it from either location doesn't remove it permanently. It's a bug. It would seem that certain applications turn it back on. Chrome, from what I gather, seems to be one of those apps. I've already had to disable the touch keyboard at least a dozen times now. –  Rob Oct 29 '12 at 15:22
3  
Exactly. The service is disabled for me. However, it is still present after a reboot –  dgraziotin Dec 18 '12 at 9:21
4  
same issue i get, even with stopping and disabling said service. i should point out this happens on my win 8 virtual machine after every suspend/reboot cycle, it reappears upon the first mouse click anywhere within the vm. –  Bobby S Jan 15 '13 at 6:51
15  
+1 for bombs... –  Inisheer Mar 29 '13 at 22:46

13 Answers 13

If you disable "Touch Keyboard and Handwriting Panel Service" it prevents it from coming back. Logging on via RDP always caused it to re-enable and it was annoying me to no end! Thank god its gone for good now.

share|improve this answer
6  
FYI: open Run; type msconfig; hit enter; Services tab; un-tick 'Touch Keyboard and Handwriting Panel Service'; click OK. –  c24w Dec 5 '12 at 10:06
14  
Weird, it turns it back on after a reboot. Ghost in the machine ... –  DeepSpace101 Dec 21 '12 at 23:04
    
I wish I could upvote this a dozen more times. –  Michael Irigoyen Feb 11 '13 at 22:57
    
Am I the only one who this doesn't work for? When my laptop returns from sleep mode, the icon comes back. Service is disabled. Weird. –  Martin Hansen Sep 27 at 18:49

Go through the following steps:

  1. Go to Manage --> Services and Application-->Services`.
  2. Double click on Touch Keyboard and Handwriting Panel Service.
  3. In Startup type .. .
  4. Click the small arrow and go to disabled.
  5. Click stop service.

Works fine for me and it doesn't come back after a reboot.

Here's a screenshot showing the details:

ss of details

share|improve this answer
    
Please stop posting multiple answers and partial answers! Use the comments if you need help! –  slm Jan 9 '13 at 1:46
1  
@slm you are right about the multiple/partial answer's but user don't have enough privilege for comment everywhere but of course he can do it under his post. :) –  avirk Jan 9 '13 at 2:52
    
also, if you would like more control over your touch pad. (ie easy disable and change the sensitivity) just google for synaptics drivers and install those. –  Hightower Jan 18 '13 at 5:59

TOUCH KEYBOARD FIX FOR VMWARE

For anyone having the Touch Keyboard Toolbar problem with VMware. The solution is very simple.

VMware adds Touchscreen support to the standard hardware for the guest even if the host machine doesn't have Touchscreen support. That's why VMware VMs using Windows 8 automatically have "Pen and Touch" and "Tablet PC Settings" in the Control Panel and also why the Virtual Keyboard Toolbar keeps showing up in the taskbar.

The virtual touchscreen hardware is available even before VMware Tools is installed and Windows is always trying to install the drivers for it.

There are two options to get rid of the Touchscreen driver

1. Go to the Device Manager / Human Interface Devices

  • Right-click Properties on each "USB Input Device" until you find the one with the format: Port_#0001 Hub_#0003
  • Right-click / Disable that device (This is the VMware Touchscreen device)

2. The better solution to completely stop the Touchscreen device from trying to load:

  • Shut down the Virtual Machine
  • Open up the Virtual Machine .vmx file into notepad.

Find the line:

touchscreen.vusb.present = "TRUE"

and change it to read:

touchscreen.vusb.present = "FALSE"

  • Save the .vmx file. Restart the Virtual Machine.

With the "FALSE" setting, the Touchscreen device won't even try to load in the first place and the Device Manager won't even list the device. This also gets rid of "VMware Virtual HiD" from Control Panel / Devices and Printers.

Both of these will disable Touchscreen support in the Virtual Machine. It will also automatically make the virtual machine a non-touch screen computer so "Pen and Touch" and "Tablet PC Settings" will automatically be removed from the Windows 8 Control Panel.

Also, if you go to: Charms Menu / Settings / Change PC settings / General section

The Touch keyboard section and Spelling section will no longer be available. One last thing it will do is get rid of 3 or 4 Event Viewer errors on each restart:

Event ID 262: A pointer device did not report a valid unit of coordinate measurement.

Event ID 255

Event ID 256

So Event Viewer is a lot cleaner without the Touchscreen driver always trying to load and failing.

It would have been nice if some of this was documented by VMware. But now you know why the Touch Keyboard Toolbar keeps appearing and a bunch of other things that aren't needed at all if you don't have a Touchscreen!

share|improve this answer
    
Excellent! I also had to turn off the touch toolbar, but this solution is much nicer than the others (for those running VMware of course). –  Mike Pelley Jun 28 '13 at 15:43
    
Superb! This was annoying me so much, and this seems to be the absolute definitive way to nuke this from orbit. Can confirm this also works for VMware workstation 9 for Windows. –  Daniel H Sep 11 '13 at 2:17
    
This worked for VMWare Fusion 7 on Mac OS X 10.9.5 –  Jon Sagara Oct 14 at 14:47
    
Excellent - thanks so much. This was quite frustrating. I will add for anyone seeing the keyboard near the system tray that you need to right-click and turn off the Touch Keyboard Toolbar if it still shows just once and then after reboot and your VMX fix, it's gone. Ding dong the witch is dead. Yeah, I said it. –  AVH Oct 17 at 17:27

Right click on the taskbar, select Toolbars, deselect Touch Keyboard

Right click on the task bar -> properties -> toolbars and deselecting it sticks.

share|improve this answer
1  
Isn't that what they said they tried? –  Joey Oct 27 '12 at 15:12
2  
@Joey Yes, you're right. The Touch Keyboard icon seems to come back after I reboot .. though not consistently. Not sure when it decides to reappear, but it does. :/ Removing my upvote .. this isn't a permanent solution. –  Chris W. Rea Oct 27 '12 at 18:43
    
@ChrisW.Rea - I think I worked out how to fix it, mind giving it a shot? Apparently I misremembered where I was supposed to turn off touch keyboard. –  Journeyman Geek Oct 28 '12 at 10:44

Disabling the service didn't seem to prevent the toolbar from coming back after sleep for me. The following seems to fix that. Note that this disables all taskbar toolbars, not just the touch input one.

  1. Press Win + R to open the run dialog.
  2. Type gpedit.msc and hit enter
  3. Navigate to User Configuration > Administrative Templates > Start Menu and Taskbar
  4. Double click the "Do not display any custom toolbars in the taskbar" setting.
  5. Select the "Enabled" radio button, hit apply, then okay.
  6. Run gpupdate /force in the command prompt.
  7. run tskill explorer in the command prompt. If explorer doesn't restart automatically after doing this, run explorer in the command prompt.
  8. You may also want to reboot after doing this.

Also note that I have the service disabled as mentioned in one of the other answers. I'm not sure whether this makes a difference or not, but as I mentioned earlier, just disabling the service didn't prevent the toolbar from coming back after the computer went to sleep.

share|improve this answer
1  
I had the toolbar appear on me everytime I rebooted or reconnected my Logitech Performance MX (or maybe it's Logitech's SetPoint software in general). Disabling the service didn't help me at all, only this did. –  hheimbuerger Feb 17 at 9:00

The laptop I purchased had all the programs installed by user TrustedInstaller. When I shutdown the On-Screen Keyboard Taskbar by disabling the checkbox, it shutdown until I rebooted.

After investigation I found it to be a permissions issue. I was logged on as administrator and it was asking for permissions from TrustedInstaller. As administrator, I took ownership of all the folders on the root of the C: drive and all sub folders and set permissions to FULL.

After I rebooted, I unchecked the box that turns on the taskbar and it went away for good. I tested it thoroughly and found that if you enable the Use Mouse and Keyboard in the Ease Of Access in control panel, it will turn it back on and you have to turn it back off by right clicking the task bar and disabling the checkbox again. Just make sure the logged on user has permission to shut it down and it will stay off.

share|improve this answer
1  
Not really a good idea, there's a reason why these files don't have full permissions by default. –  gronostaj Mar 26 '13 at 17:54

I have this problem in VMware Virtual Machines only when coming back from sleep. Disabling the service doesn't work. The Touch Keyboard Toolbar reappears after coming out of sleep every time.

I thought deleting the service entirely would work but it didn't.

I finally got it to work but I'm not sure how. I updated Windows with all the latest updates including optional updates. But I also tried the answer above this. I used "Take Ownership" on all the main folders under c: and then rebooted and turned off the Touch Keyboard Toolbar. It didn't show up in the VM after coming back from sleep. So maybe that's what fixed it. It would be nice if someone found out specifically which folder needed full permissions because I'm not going to take full permissions of everything on a real machine.

Edit: I finally figured out the problem with VMware Workstation 9. I had the VMware USB 3.0 device installed in the Virtual Machine but I don't have USB 3 on the host. Either way, I downgraded the VM to USB 2.0 and I can now wake from sleep with no more Touch Keyboard Toolbar. I still think something is wrong with Windows because a USB 3.0 error should never trigger enabling a Toolbar. There are probably other things that set it off too.

share|improve this answer

Personally, I just used the nuclear option of deleting the Touch Input Panel dll file. For me, this file is located at C:\Program Files\Common Files\microsoft shared\ink\tipband.dll. Note that, first, you will have to take ownership of the file from TrustedInstaller using the Security tab in file properties. In addition, because explorer.exe loads the file when it starts up, I first had to terminate explorer.exe from the Task Manager, and then use an elevated command prompt to delete this file.

So far so good, and the touch keyboard taskbar toolbar hasn't appeared, even after multiple computer restarts!

share|improve this answer
    
This didn't work for me. Reappeared after login –  B T Oct 22 '13 at 3:06

I wouldn't mess around with the above solutions of attempting to take ownership of all the system folders, as that may compromise system security.

For the following solution, read only the bold text for a TL;DR.

I had this same issue with my ASUS G75VW. Since you're also on a laptop, I'm willing to wager you have some sort of drivers installed for your touch pad, just as I did. It's likely that such drivers are the same ones you've had installed since you had Windows 7.

First, try attempting to uninstall your touch pad drivers via Control Panel (the driver might be listed as "Synaptics Touch Pad Driver"). If you can't find it there, press Win+X and attempt to locate it in Device Manager, potentially in the section where you might find input devices.

Then, restart your computer. After restarting, you'll see that touch services should no longer be invoked, and your tabs in Firefox should no longer be huge (that's one of the symptoms that I had on my computer, so I'm listing it here for search engine purposes). You can now proceed to update your touch pad drivers to the version compatible with Windows 8.

share|improve this answer

I had the same issues, the icon reappeared every time.

But after I installed the newest Synaptics driver (16.3.15.1 ?) an made a reboot, the taskbar icon finally disappeared. And: I unchecked 'Enabled Edge Swipes'.

share|improve this answer

My particular case is apparently different from most other users. I tried all the posted fixes to get the touch keyboard icon to vanish from my taskbar and they all failed. I finally figured it out. A while back I bought a Logitech T650 Touchpad and installed it. I used it for a few days then returned it. That's when I noticed the icon on my taskbar. I went into the setpoint software settings, clicked on unifying software settings, then advanced, then I unchecked the T650 from the list of devices. Success! The touch keyboard is still listed in the toolbar choices but doesn't appear on the taskbar, I hope my experience will help others.

share|improve this answer

This is the simplest way I know of to prevent Touch Keyboard from showing up again. It only involves a simple registry key change. It works on all Windows versions after XP and will also disable the language bar.

You'll need to end and re-launch Explorer to take effect right now, otherwise it will happen next time you restart.

Add a registry key called NoToolbarsOnTaskbar and set the value to 1. The path is \Software\Microsoft\Windows\CurrentVersion\Policies\Explorer and you'll want it defined in in HKLM (if you want to affect the whole machine) and HKCU (if you only want to affect your current user)

In the case of Windows 8.1, The Explorer folder on the registry may not exist. If so, create it and the previous key. Ending Explorer in Task Manager may provoke a BSOD in this platform.

share|improve this answer

For me, disabling the service didn't work. However, there is another way I found through the registry.

  • Open regedit and navigate to HKEY_CLASSES_ROOT
  • Then open search and search for "Tablet PC Input Panel"
  • After you found it, delete the whole CLSID folder it's in. For me it was "{15D633E2-AD00-465b-9EC7-F56B7CDF8E27}". Backup / export the key before in case something goes wrong.
  • You may have to take ownership for this key to be able to delete it. Do do this, right-click the CLSID key (folder) and every of its sub-keys, open the permissions menu, and take ownership for all keys.

After I done this, the toolbar was gone for good. A safer way should be to deny system read permissions for this key, however I didn't have the time to figure out how.

share|improve this answer

protected by Community Sep 27 '13 at 15:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.