Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble getting my keyboard layout to be properly recognized. At the moment everything else is fine, but my less-than key (<) is mapped to the section key (§), which makes writing HTML a pain. I've tried Ukelele and KeyRemap4MacBook, but can't seem to find the correct settings to change.

For reference, this is my layout: Finnish Multilingual, and in System Preferences the input is set to Finnish.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Did you try saving something like this as private.xml?

<?xml version="1.0"?>
<root>
<item>
<name>test</name>
<identifier>test</identifier>
<autogen>--KeyToKey-- KeyCode::SWEDISH_SECTION, KeyCode::SWEDISH_LESS_THAN</autogen>
<autogen>--KeyToKey-- KeyCode::SWEDISH_LESS_THAN, KeyCode::SWEDISH_SECTION</autogen>
</item>
</root>

The key code constants are defined in the source. The test folder has an XML file with all the predefined remappings.

share|improve this answer
    
Worked perfectly, thanks! –  onik Oct 25 '12 at 6:06
    
I was going around in circles with this for a while. Couldn't find the correct keycodes. This finally solved it, thank you. –  keyser Jan 29 '13 at 8:35

After upgrading from Lion to Mountain Lion I had the same issue using a Logitech keyboard and the Spanish ISO layout.

Take a look at your /Library/Preferences/com.apple.keyboardtype.plist file using a Property List Editor. It may look something like this:

Root
  keyboardtype
    49949-1133-0      43 

Replacing 43 with a 41 solved the problem for me:

Root
  keyboardtype
    49949-1133-0      41 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.