Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 RTM with homegroup, network discovery, file and printer sharing, public folder, media streaming and Windows Media Player Network Sharing Service all turned off, but the computer still doesn't go to sleep. powercfg -requests shows this:

PS C:\Windows\system32> powercfg -requests
DISPLAY:
None.

SYSTEM:
[DRIVER] \FileSystem\srvnet
An active remote client has recently sent requests to this machine.

AWAYMODE:
None.

Running ipconfig /release doesn't help, and netstat -n -o -b shows this:

PS C:\Windows\system32> netstat -n -o -b

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP    127.0.0.1:27015        127.0.0.1:49179        ESTABLISHED     1616
 [AppleMobileDeviceService.exe]
  TCP    127.0.0.1:27015        127.0.0.1:49181        ESTABLISHED     1616
 [AppleMobileDeviceService.exe]
  TCP    127.0.0.1:49179        127.0.0.1:27015        ESTABLISHED     3976
 [iTunesHelper.exe]
  TCP    127.0.0.1:49181        127.0.0.1:27015        ESTABLISHED     3976
 [iTunesHelper.exe]
  TCP    127.0.0.1:49209        127.0.0.1:27015        TIME_WAIT       0
  TCP    127.0.0.1:49555        127.0.0.1:27015        TIME_WAIT       0
  TCP    [fe80::9075:f418:87dd:8288%11]:445  [fe80::9075:f418:87dd:8288%11]:49202  ESTABLISHED     4
 Can not obtain ownership information
  TCP    [fe80::9075:f418:87dd:8288%11]:49202  [fe80::9075:f418:87dd:8288%11]:445  ESTABLISHED     4
 Can not obtain ownership information

What is \FileSystem\srvnet anyway, and how can I allow my computer to go to sleep automatically?

Disabling Wake-On-LAN from device manager didn't change anything, but disabling the network adapter and then re-enabling it did. The SMB over TCP/IPv6 link-local connection at the end vanished, and powercfg -requests showed no issues preventing sleep mode. Unfortunately, after a few moments the connection pair reappeared, this time using the IPv6 loopback address:

  TCP    [::1]:445              [::1]:49401            ESTABLISHED     4
 Can not obtain ownership information
  TCP    [::1]:49401            [::1]:445              ESTABLISHED     4
 Can not obtain ownership information

Now disabling the network adapter doesn't help anymore, but stopping the Workstation service did. Why would the system establish an SMB connection to itself?

share|improve this question
add comment

1 Answer

Srvnet is the "server network driver". This is likely your NIC having the Wake On LAN issue just like Vista.

  • Go to Network Connections
  • Right click your Local Area Ethernet adapter and hit properties
  • Open the power management tab, and uncheck "allow this device to wake the computer"
  • apply & OK

alt text

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.