Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I successfully created a batch file to flush my DNS.

I have added a pause, I noticed in the title bar of the console window… It's not running as administrator.

I've already tried a couple of variations of this… Just a little guidance would be most appreciated.

I remember reading a blog somewhere, it said something about capitalization wasn't important… Is camel casing important in writing batch files?

@echo off
echo.
pause
CD..
CD..
echo.
runas /user:<Administrator> ipconfig /flushdns
echo.
pause
echo.
share|improve this question
    
This has been answered already at: superuser.com/questions/788924/… – Antp Oct 27 '14 at 2:38

The user name must be in one of the following two forms:

If you want to use the Administrator account on your computer, for the /user: parameter, type one of the following:

/user: AdministratorAccountName @ ComputerName
/user: ComputerName \ AdministratorAccountName

The spaces around the "@" and the "\" should not be present - I suspect that they are there to make it easier to read.

Source

share|improve this answer
    
@RandolphWest - I wondered about that, but that's how it's written in the Technnet documentation. – ChrisF Oct 16 '12 at 16:25

Either Press and hold Ctrl+Shift while opening the program or Right click on the program and click on Run as administrator.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .