Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a LAN comprising several mac machines (iMac, Mac Pro, macbook etc.), Airport Express router and Mac Mini Server running OS X Server 10.8 (Mountain Lion Server). I need to share a folder on Mac Mini Server by FTP.

What did I try so far:

  • Made special partition for FTP Access, call it "Reports" So shared folder would be "/Volumes/Reports"

  • Gave access every user and group in system, and also enabled guest access. I checked posix acl, which is "rwxrwxrwx", I checked sharing settings in "Preferences.app" and "Server.app"

  • Checked that users have access to FTP service

  • Enabled FTP in Server.app

I tried access to shared folder (by FTP):

  • via Cyberduck
  • via Finder
  • via shell: ftp server.local

And what I got:

$ ftp ftpuser@server.local
Trying 10.0.2.2...
Connected to server.local.
220 10.0.2.2 FTP server (tnftpd 20100324+GSSAPI) ready.
331 User ftpuser accepted, provide password.
Password: 
530 User ftpuser may not use FTP.

and

$ ftp admin@server.local
Trying 10.0.2.2...
Connected to server.local.
220 10.0.2.2 FTP server (tnftpd 20100324+GSSAPI) ready.
331 User admin accepted, provide password.
Password: 
530 User admin denied by SACL.
ftp: Login failed
ftp> 

(admin is administrator account , ftpuser is special user account made to access ftp)

What I'm doing wrong? Getting really tired of this...

UPD contents of /etc/ftpusers

$ cat /etc/ftpusers
# list of users disallowed any ftp access.
# read by ftpd(8).
Administrator
administrator
root
uucp
daemon
unknown
www

SOLUTION

User account must have home folder (/Volume/Reports in my case), users without home directory can't access FTP share; ALSO user account must have valid shell (/bin/bash)

share|improve this question
1  
For ftpuser, check that it's not listed in /etc/ftpusers. For admin, could you post /bin/ls -laed /Volumes/Reports? –  jaume Oct 16 '12 at 19:17
    
For admin, the problem partially solved. FTP became available (I forget to enable FTP in "Services" for user indeed) –  Oleg Trakhman Oct 17 '12 at 13:02
    
ftpuser isn't listed in /etc/ftpusers; Updated my answer –  Oleg Trakhman Oct 17 '12 at 13:05

1 Answer 1

up vote 2 down vote accepted

Sounds like your users aren't on the service access control list for the FTP service. Check in the Users section of Server.app by selecting the user, then choosing "Edit Access to Services" under from the action (gear icon) pop-up menu.

share|improve this answer
    
Thank you, Gordon! Indeed, "admin" account wasn't, but problem with another account (ftpuser) remains. I check that ftpuser has access to the FTP. I actually need to access this share with account other than administrator. –  Oleg Trakhman Oct 17 '12 at 13:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.