Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wasn't able to get the brightness working. So far I've tried:

  1. Controlling via /sys/class/backlight/acpi_video0

    • max brightness was 15
    • does not respond to "echo 5 > /sys/class/backlight/acpi_video0/brightness"
    • "cat /sys/class/backlight/acpi_video0/actual_brightness" shows 5 but have no effect
  2. Controlling via /sys/class/backlight/intel_backlight

    • changing the brightness value will result in screen flicker
    • have to max it out to get rid of the flicker

Does anyone have arch working on this model? I'm lost.

share|improve this question
add comment

2 Answers

Backlight

Hi, you can try xbacklight. For example,

# xbacklight = 20

where the value ranges from 0 to 100

It should come along with the xorg-apps package. If not, you can get it from extra

# sudo pacman -S xorg-xbacklight

Graphic Driver

Do make sure you have installed the correct graphic driver for you notebook, or else your xbacklight will give you an error message "No outputs have backlight property"

Refer to Dell, your notebook uses Intel® HD Graphics 3000

The correct graphic driver to install will be xf86-video-intel (64-bit) and lib32-intel-dri (32-bit).

If you are installing your Archlinux in 64 bit, you can do the following:

# sudo pacman -S xf86-video-intel lib32-intel-dri

If you are installing your Archlinux in 32 bit, you can do the following:

# sudo pacman -S lib32-intel-dri

Enjoy :)

share|improve this answer
add comment

There is a temporary workaround script available at the Arch Linux forums — all credit to tyler.heck I'm just posting it below.

through trial and error I've found that I need to set /sys/class/backlight/intel_backlight/brightness to 0 before changes to /sys/class/backlight/acpi_video0/brightness will affect actual screen brightness. You will need to do this regardless of whether the intel_backlight/brightness is already set to zero, the act of setting the value is what allows the acpi_video0 interface to change the brightness.


#!/bin/bash

# set intel interface to 0, allowing acpi interface to take precedence
echo 0 > /sys/class/backlight/intel_backlight/brightness

# set the permissions of the acpi brightness file for convenience of non-root modification
# (works if user is a member of the video group)
chgrp video /sys/class/backlight/acpi_video0/brightness
chmod 664 /sys/class/backlight/acpi_video0/brightness

# initialize brightness to a low level
echo 3 > /sys/class/backlight/acpi_video0/brightness

exit 0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.