Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Gmail account with a lot of filters, that sort incoming e-mails by adding labels to them. All of my e-mails have at least one label.

When I try to synchronize my Outlook 2010 client with Gmail account via IMAP it stores every e-mail in INBOX folder, THE SAME e-mails are also in Gmail/All_messages AND also in every LABEL folder that corresponds to each LABEL added to e-mail. This way I have a lot of e-mail duplicates and after a few months my IMAP file has a few GB.

Is there a way to completely disable Outlook's INBOX folder, Gmail/All_messages and have the e-mails only in corresponding LABEL folders? Will any Outlook rule help for this case?

Something like:

If ( e-mail_has_a_label() ) { dont_store_in_INBOX(); store_in_label_folder_only(); }

share|improve this question

migrated from stackoverflow.com Oct 16 '12 at 17:50

This question came from our site for professional and enthusiast programmers.

    
This should probably be at superuser. –  Max Oct 16 '12 at 15:08
    
Also, IMAP has no concept of labels: this is how Google exports labels: as fake folders. –  Max Oct 16 '12 at 15:10
    
Thank you for moving the question. I didn't know about SuperUser.com Yep, I know, I was thinking about some workaround - like creating some rule in Outlook to remove incoming e-mails from Inbox folder, and to not synchronize Inbox folder with Gmail, just the other folders (label folders). Is it possible? –  Joudicek Jouda Oct 16 '12 at 20:28

1 Answer 1

up vote 3 down vote accepted

In the end I solved the problem by unsubscribing from IMAP folders I didn't want to use. In my case it was: - Gmail/All_messages - Gmail (Gmail - Inbox)

To do it, you just go to Folder => IMAP Folders => and deselect those you don't want to download to Outlook.

Another option is to go to Gmail web mail (gmail.com) => Settings => Labels => And set labels you don't want to synchronize with Outlook to not show in IMAP access

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.