Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my browsers, links are created on random words within a text and when I hover over them a small ad window pops up, which is quite annoying.

I read here that this is called Intellitxt and that webmasters add them to pages intentionally and that to turn them off I can disable Javascript for those pages. But that's not a good idea for me as these Intellitxts appear almost on every page for me, including on stackoverflow.com and I might break other things by disabling Javascript.

It's hard to believe that someone thought that this would be a good feature to add to their website, moreover, my colleague doesn't get them on his computer on the same websites where I get them.

Does anyone know another way of how to get rid of these? Here's an example of one. When I hover over the word "open" this ad window pops up.

ps.: I'm using Windows 7 Professional, and my browsers are Google Chrome 22.0.1 and I.E. 9.

enter image description here

share|improve this question
add comment

migrated from stackoverflow.com Oct 16 '12 at 20:14

This question came from our site for professional and enthusiast programmers.

9 Answers

up vote 8 down vote accepted

If they are occurring on sites like stackoverflow it's most likely from a browser extension or some type of malware installed on your computer.

Start by looking at the enabled browser extensions and disabling those you don't recognize. Then find a good spyware and anti-virus program and run those.

It was apparently a Google Chrome extension called Savings Sidekick. I disabled that and I don't get the links anymore.

share|improve this answer
add comment

Does this happend everywhere? If so you probably got some malware. If not, try Greasemonkey/Tampermonkey, there is a version for Chrome.

share|improve this answer
1  
Could you link to the add-ons/extensions you recommend, and clarify how the OP should use them? Also, if this is a case of malware, how would he go about getting rid of it? –  Indrek Oct 16 '12 at 20:38
    
@Indrek - Why should he link to the add-ons? He indicated they were Firefox ( clearly based on the face its Greasemonkey ) and indicates there is a version for Chrome that exists. –  Ramhound Oct 17 '12 at 11:42
    
@Ramhound Simply so as to provide a complete answer. While it may be obvious to you and me where to find the add-ons, it may not be so for the OP, or future visitors to this question. –  Indrek Oct 17 '12 at 11:54
add comment

In my case it was a firefox extension called LyricXeeker. I disabled it -- problem solved ;-)

share|improve this answer
add comment

Similar to above response, I found an extension running titled "Solid Savings" in Chrome. After clicking the trash can and deleting it the ads went away.

share|improve this answer
add comment

As mentioned before, this can be caused by malware or adware. However, if you have already ran the proper software to check for that and nothing came up, it is likely to be a browser extension.

You can disable them one by one, but here is a more efficient way to deal with this if you have many plugins/extensions:

  1. Check which extensions are enabled, remember this as 'the list'
  2. Switch of all extensions and go to step 4
  3. Make sure the top half of the list is enabled and the bottom half of 'the list' is disabled
  4. Close all instances of the browser that you use and go to a website where the underlining occured
  5. If you see that the problem is still there, the selected plugins from 'the list' become 'the list', otherwise the nonselected items become 'the list'
  6. As long as you don't know which plugin is the cause, go to step 3.
share|improve this answer
add comment

This may help for some:

The only extension I had in chrome was google docs. Didn't take a second look at it for several days, then decided to delete it just in case. It solved the problem. So even extensions that are cleverly named to deceive you may still be the cause.

share|improve this answer
add comment

The in text links are something that is installed in your Internet program, so while in the Internet go into your tools and click extensions and then un-click and re-click all extensions to find the culprit.

It is a little repetitive, but I was so glad to have removed the add extension.

This should fix any problems you are having.

share|improve this answer
add comment

I went to Extensions (On Mac OS X, Window menu > Extensions; also accessible through Preferences, or CMD-",") and deleted "Torrent Handler" ... I don't think I installed that recently (or someone else, like my boyfriend could have), but either way the links are gone! They were really getting annoying, and I thought Adblock would stop them, but it didn't. Hope this helps. :)

share|improve this answer
add comment

I disabled the extension World Clock and got rid of this annoying ads.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.