Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having one application which runs on XP very well. What it does is it downloads some files from server and register one ocx object. In XP after installing I am able to see the entry in the RegEdit with name of that ocx component. But same thing I tried on the Windows 7 and its not registering that ocx component. I having same access rights as XP on windows 7. I am unable to find any entry in RegEdit. I tried installing it manually by Running Command Prompt As Administrator then it installs successfully..

How can I do it automaticallly as it works in XP? Thanks for the help.

share|improve this question

migrated from stackoverflow.com Oct 16 '12 at 21:58

This question came from our site for professional and enthusiast programmers.

1  
Remember that Windows Vista and above has Registry Virtualization - msdn.microsoft.com/en-us/library/windows/desktop/… - which is part of the security changes in these OSes. Since you can complete the action as an administrator this surely means that it's security issue? Your program as current need to run with Elevated Security Permissions. –  Preet Sangha Oct 16 '12 at 21:25
    
is it means i am having diferent permissions on xp and windows 7? –  Naren Oct 16 '12 at 21:43
    
Yes you need to do a whole load of reading on User Access Control and other Vista + security changes. The OSs have lots of security differences. –  Preet Sangha Oct 16 '12 at 21:50
    
Thanks for Preet. Can you please add your comment as answer so that I can accept it. –  Nalu Oct 17 '12 at 13:54
    
I dont have the Admin Rights on the XP also but still I am able to register component. –  Nalu Oct 17 '12 at 21:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.