Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently replaced my couple years old SuperTalent SSD with a newer Intel SSD 330 128GB. I got two of those same Intel SSDs, one is the OS disk for a fresh install of Windows 8 RTM and the other disk is for some data. The problem is that both of these disks seem to "lag".

Examples:

  • I open the "Open file..." dialog in Notepad / Visual Studio / Paint.net. I decide to cancel the dialog. The program hangs for 2-5 seconds. (Happens with all the programs).
  • I create a new text file on the desktop. The file is hidden for 1-10 seconds before it appears.
  • I create a new folder on the disk. I have to hit F5 in order to see the folder. I rename the folder and I again have to hit F5 to see the new name.
  • I start a download in Chrome. The UI hangs for 3-5 seconds before the download appears in the bottom bar.

And so on. The loading times of apps are also way off, Visual Studio 2010 being the worst. With the old SSD the VS2010 was started in few seconds, now it's near a minute. I also have a mechanical drive on my system but it seems to be performing just fine. Actually I've started to use it more now because it feels snappier than my SSDs...

If I copy large files, everything seems to be working OK. It's just when the OS tries to access some file, there's this irritating lag.

I did some benchmarks with CrystalDiskMark 3.0.1:

  • Seq Read: 440.1 MB/s
  • Seq Write: 131.5 MB/s
  • 4k Read: 18.61 MB/s
  • 4k Write: 62.11 MB/s

These seem to indicate that the Seq Write is slow? I've made sure that the "Sleep hard disk" options are turned off from the Windows. Also I've tried the regular stuff like updating the bios of the motherboard. But as I mentioned, the previous SSD worked excellently with Windows 7.

Any ideas? Is there some test tool which I could run to really pinpoint the problem?

Info about the rest of the system:

  • i7 2600K (default clocks)
  • ASRock P67 Pro3 SE

Update:

Last week, for three days, the computer was "the fastest ever". The problem: I was out-of-office for those three days, and I had the computer with me. For those few days the computer was as snappy as it should be. When I brought the computer back to it's regular place, it started acting up again. It's bizarre and I'm now wondering if there's something in the network which is causing this. I've been monitoring the situation with Resource Monitor but haven't spotted anything out of ordinary.

Yeah, it's bizarre and I'm getting little frustrated with the issue.

share|improve this question
    
Have you checked for updated motherboard storage drivers? And for updated SSD firmware? Unfortunately the world of SSDs is still quite hit or miss with drivers/firmware/chipset/OS combinations. –  Mufasa Oct 28 '12 at 16:21
    
I've updated all the drivers and motherboard bios. I'm not sure if there's new bios available for the SSD. I also updated the question with new info. –  Mikael Koskinen Oct 29 '12 at 13:28

2 Answers 2

Try the Intel Solid-State Drive Toolbox. This has a few functions, such as 'SSD Optimizer', Firmware Update and System Tuner, which may help you resolve your problems.

share|improve this answer
    
Thanks for the tip. I tried it but unfortunately it didn't seem to trick. I had some problems getting it running, but with the Windows 7 compatibility mode everything seemed to work. –  Mikael Koskinen Nov 2 '12 at 8:10
up vote 0 down vote accepted

After couple days of testing, it seems I've been able to resolve the issue. The issue seems to be somehow related to Windows 8's "Fast Boot" feature which uses the hibernation to store something to the disk, making the OS to startup faster.

I disabled the hibernation using the following command and everything seems to be running just much better now:

powercfg -h off

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.