Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

MMC Snap-in will not load most processes and throws an error on Windows 2008R2 x64. It gives the error:

mmc could not create the snap-in. CLSID: FX:{18ea3f92-d6aa-41d9-a205-2023400c8fbb} when opening server manager.

It also gives similar errors opening the event viewer, etc. I think that the .NET Framework is messed up but I can't narrow down the exact cause. Has anyone else seen this issue? I have a dmp file of mmc.exe but haven't been able to get anything meaningful out of it.

share|improve this question

migrated from stackoverflow.com Oct 17 '12 at 13:20

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Check out this thread. It sounds like a corrupted update.

share|improve this answer
    
Yeah I Saw that but the weird thing is all of my system scans pass with flying colors. I have another machine that works and it doesn't have any references to that update. I am guessing because i'm on 2008R2 and not just 2008. –  Tammy Jan 4 '11 at 16:02
    
Based on that and this: jaredheinrichs.com/… it seems that this is often caused by a problem with a .net installation (more specifically a corrupted machine.config). In most cases, people seem to simply rebuild the machine; however, if that is out of the question (and you have some free time) would it be possible to uninstall and reinstall .net? –  Bobby D Jan 4 '11 at 20:06
    
Well I think I figured out what is going on. Our application has a windows group that is assigned permissions on the GAC folders. When I delete the group the snap in breaks. The weird thing is that administrators still have access to the GAC according to the permissions but that doesn't seem to apply anymore when the group is deleted. If I go and remove the references to the group on the GAC security it also removes the administrators access. You are locked out of re-installing .NET since Server Manager does not open and its a part of the OS on Windows 2008R2. –  Tammy Jan 5 '11 at 20:01

I was having same issue, but it worked just fine, when i removed .Net 3.5 from my system, and just by that removal everything got back to normal .. this looked to be a problem with .net itself, i have not tried to install 3.5 again when i will do that will update the thread

share|improve this answer
    
CLSID : FX: Snapins can not work without .NET, so you still have other version of .NET installed, isn't it? –  rkosegi Oct 17 '12 at 11:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.