Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to lock down and secure some of my computers, and I've been able to disable USB Mass Storage. However, I can connect my phone and it still acts like a mass storage, but it uses the MTP protocol. I can't simply disable all USB ports, since I have USB keyboards and mice. I was given advice by a friend that the way he usually solves this issue is simply super gluing the USB ports shut. This sounds a bit extreme. What are my options?

share|improve this question
How did you disable the USB Mass Storage? Are you sure that's working? (IE: if you plug a regular USB flash drive in right now, does it get blocked?) – Ƭᴇcʜιᴇ007 Oct 17 '12 at 16:02
Related from over on ServerFault: Disable writing to “portable media player” – Ƭᴇcʜιᴇ007 Oct 17 '12 at 16:09
@techie007 Yes, I've tested it thoroughly. Mass storage is in its entirety disabled. – Drise Oct 17 '12 at 16:17
Surely this can be done in the group policy editor. – Moab Oct 17 '12 at 17:08
@Moab Not that I've found. Unless I missed something. – Drise Oct 17 '12 at 17:11
up vote 3 down vote accepted

Try by setting the policy WPD Devices: Deny read access within System\Removable Storage Access to "Enabled" and this should block all the portable devices.

share|improve this answer

This is not an elegant solution and would have to be performed for each MTP device, by changing the driver used by the device you can have it use the usb mass storage driver, which you have blocked.

share|improve this answer
No danger of link rot here? – Karan Oct 17 '12 at 22:08
Feel free to edit my answer and include the info, I will do it when I have time. – Moab Oct 18 '12 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .