Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server connected to the router which has ubuntu 12.04. It is has apache/mysql/php all installed ready to go. the folder structure is like this:

/var/www -- this isnt the root
-/libs
-/logs
-/public - this is the root
-/vhosts - all subdomains go here

I have a folder in vhosts named mysite. I went into /etc/apache2/sites-available and created a file and here are the contents -> (vhost file). and I also added an entry in /etc/hosts file containing: 127.0.1.1 mysite.dev and I also did

sudo a2ensite mysite

i tried accessing the site from a computer via mysite.dev and our public ip into the server but i was not able to view it. the public directory in the structure above does display on all computers when i try our public ip. but for anything added in vhosts the site wont show. there is no domain attached its just our ip. I tried changing the port from 80 to say 9999 in the mysite file in sites-available and tried myip:9999 but that didnt work either. what am I doing wrong?

share|improve this question
    
If you're going to change the port, you need to change it everywhere, including in the router's port forwarding configuration. –  David Schwartz Oct 17 '12 at 18:14
    
oh i forgot to mention that the router for that computer has dmz set on. So all ports are open And nothing still works –  Sarmen B. Oct 17 '12 at 18:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.