Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 desktop (64-bit) that has both a wireless and wired adapter. I have been able to successfully assign the wireless with a static IP address of 192.168.1.169 but when I try to assign the wired adapter to 192.168.1.150, and choose to have it validate on close, it wants to fix the DHCP, which in turn removes the static info I put in.

If I tell it not to validate on close, it will not work at all, it says Unidentified Network.

How can I disable the DHCP? I tried assigning it, not validating, then power cycling the computer and router, but no luck.

Any help you can give would be greatly appreciated.

share|improve this question
add comment

2 Answers

How can I disable the DHCP?

From the 'Network and sharing center':

  • Left click on the NIC
  • Select 'properties'.
  • Select 'Internet protocol version 4 (TCP/IP v4)
  • Select 'properties'.
  • Change the point from 'Obtain an IP address automatically` to 'Use the following IP adress'.

Since you already tried setting a manual IP you already been to this place.

You need to fill in at least two fields: 'ip address' and Subnet mask. (One without the other is useless). Did you enter values in both of these before trying to exit?

The remaining fields are the default gateway and the DNS servers.

You do not need to set a default gateway, but if you do not set the default gateway then you will not be able to reach the internet, or any other machines not on your local subnet.

Similarly you do not need to set DNS servers. Not setting a DNS server means you will have to type IP addresses rather then hostname.

I recommend looking at the current values of both of these (and the netmask), and then returning to this screen and trying to set the IP again. (With 'Validate settings upon exit` ticked).

If you do not know what all these things mean, then I recommend taking a look at how-does-ipv4-subnetting-work.

share|improve this answer
add comment

I too have had a similar problem. Every time I set the static IP it would change back to DHCP. I found and corrected the problem. I have a Lenovo laptop that is running all the Thinkpad tools, Access Connections to be precise. This network interface manager takes precedence over Microsoft and I only needed to create a static IP profile in Access Connections and all is good again.

I imagine there are other network configuration tools/aids out there that probably act the same way. Access Connections is really very nice, I just never made the connection that it would prevent changing the network interfaces thru the OS panels.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.