Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

if i use

cd C:\Program Files (x86)\GnuWin32\bin

then i'm able to use wget commands

for example:

wget http://www.ultralightnews.com/trikes/images/trikes/dfs-singletrike.jpg

but i can't find the file back, i looked in c:\ and in the bin folder mentioned above and in GnuWin32\etc

If i try

wget -O C:\Users\clankill3r\Downloads\wgetfolder wget http://www.ultralightnews.com/trikes/images/trikes/dfs-singletrike.jpg

then it says Permision denied, i did allow all permisions possible for every group / user.

Some people say it downloads to the current folder your working in (that's why i looked in the bin). But i thought let's try to run the command from another folder so i used:

'cd C:\Users\clankill3r\Downloads\wgetfolderand then the wget comman but then it says thewget` command is not recognized.

can someone help?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

If you use cd C:\Program Files (x86)\GnuWin32\bin then your current directory is just that. If it is allowed to write in that place it will write the file to that place. However I really hope that is is not allowed to write in program files.

(Still, that should not cause a silent failure. It really should give an error).

cd C:\Users\clankill3r\Downloads\wgetfolder makes the wgetfolder your current folder. If you do it that way document will end up there.


So much for the locations where your downloaded files should end up.

The command not recognised is an other issue. When you type a command windows looks for hat command in a few places. One of them is the current directory. The others are specified in %PATH%.

You probably did not add C:\Program Files (x86)\GnuWin32\bin\ to the path. (you can check this but typing path in a cmd window). On your first try you accidently started to command from the directory in which it was stored, and thus did not run into this problem.

To solve that, either specify the full path to the program, or add it to %path%

Full example:

C:\Program Files (x86)\GnuWin32\bin\wget.exe http://www.ultralightnews.com/trikes/images/trikes/dfs-singletrike.jpg

Path adding: (via GUI)

  • [My computer], right click
  • properties
  • Advanced system settings
  • Environment variables.
  • [Edit] (either per user, or system wide)

enter image description here

share|improve this answer
    
thanks, i will try when i'm home. For path adding, how must i name the variable? And i have to locate to the bin folder right? –  clankill3r Oct 18 '12 at 8:54
    
You do not need to name a new variable. Use the existing one named path. Select it, click edit. It will show a number of search paths seperated by a ;. Append ;C:\Program Files (x86)\GnuWin32\bin\ to that. –  Hennes Oct 18 '12 at 15:49
    
thanks, you have been a great help –  clankill3r Oct 18 '12 at 20:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.