Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Thunderbird 12.0.1 with the following add-ons for the calendar:

  • Lightning 1.4
  • Provider for Google calendar 0.9

I'm working with Ubuntu 12.04

When I receive an event invitation from Outlook or Gmail, the mail is correctly identified by Thunderbird (I have the message "this message contains an invitation to an event"). In the pretty little box in the mail (the one which contains all the details), there is no "Accept" or "Decline" button.

I found on the Lightning forum that this bug was fixed in Lightning V.1.0b2.

So, why am I still experiencing this bug?

share|improve this question

migrated from stackoverflow.com Oct 17 '12 at 22:33

This question came from our site for professional and enthusiast programmers.

10 Answers 10

up vote 4 down vote accepted

I use a Google Calendar with Thunderbird/Lightning and I have always been able to Accept invitations through Thunderbird.

I recently lost the Accept/Decline buttons and just figured out the problem. I had recently added a shared iCloud calendar, and the new calendar was automatically associated with the same email address as the Google calendar.

All I had to do is set the iCloud calendar to not be associated with my email address, and my Accept/Decline buttons came back.

share|improve this answer

Here is my work-around using Thunderbird 17.0.4, Lightning 1.9.1, and Provider 0.18. Double click on the invite so it is in its own tab. Right click on the email invite and a sub-menu appears. Select 'Convert to' and then a smaller sub menu window appears with "Google task", "Event", or "Task".

Select "Event" and it will place the details of the invite as a new appointment in your Google Calendar. The click ok.

share|improve this answer

According to multiple threads I've found, Google cal does not support "Accept" or "Reject" somehow. http://forums.mozillazine.org/viewtopic.php?f=46&t=1826045

The solution was to set the "Automatically add invitations to my calendar" option, but it doesn't say whether on gmail or in lightning.

Just found a solution for me (not-a-google-calendar) - the calendar has to be associated with the email! http://web.archiveorange.com/archive/v/fdCyh9sjQ8kzJuM5rPM4

The "display attachments inline" option seems to be irrelevant in my versions - TB 16.0.1 , Lightning 1.8

share|improve this answer

Here is my work-around using Thunderbird and Lightining. I read/write google calendar through CalDAV https://support.google.com/calendar/answer/99358?hl=it I think that is the only way to bind the email with google calendar. So, when you receive an ics attachment, you can Accept/Decline invitation on your google calendar. Hope it helps.

share|improve this answer

I tried adding my calendar using ics, caldav several times and was unable to do so as the calendar was unwriteable. This meant I could not accept invitations. What I found was that if I added the google calendar, then exited thunderbird, then restarted thunderbird I was prompted to upgrade the newly added calendar to a writable calendar. When I did the upgrade, everything works great. Lightning now reads and write to my google calendar account and the accept, decline, ignore buttons work perfectly.

Additionally, I had to add Providor for Google Calendar 0.25 to get the accept, decline, ignore buttons to appear.

share|improve this answer

Under Properties for your google calendar, enable the email address associated with your google calendar.

share|improve this answer

In the current version (0.18 with lightning 1.9.1), this is a hidden feature which is disabled by default. It is slightly buggy, but works sufficiently to just get an invitation into your google calendar from your (possibly non-google) inbox.

Using the config editor, simply set calendar.google.enableEmailInvitations to true. You may also want to set calendar.google.sendEventNotifications to false to avoid the possibility of an old bug that sent new events instead of notifications; I've not tested this. Then, restart thunderbird.

Once you have done this, in the properties of your google calendar, you will have the option to associate it with an account.

If it still does not work, try deleting and reconnecting your calendar via the xml-address from the Google Calendar website.

After you do that, you will get the appropriate buttons (they will appear with a brief delay as your google calendar is checked to see if the event exists). If it doesn't, you can use the accept/decline/tentative buttons as with other calendar types.

One bug that currently exists is that if the event is in your calendar already, you will get an update button whether there is any change or not. The button will usually cause an error if pushed.

share|improve this answer
1  
I'm such a newbie I needed this link: support.mozillamessaging.com/en-US/kb/… for "how to get to the config editor" Hope it helps someone. –  FlipMcF Aug 16 '13 at 22:59

This article has a few useful hints and helped me fix the issue of no accept button.

Simple create a new network calendar with URL: https://apidata.googleusercontent.com/caldav/v2/your-email-address/events

Replace: your-email-address with your @googlemail.com address. Make sure it's @googlemail.com and not @gmail.com

share|improve this answer

I've suffered the same symptoms but with the following configuration:

  • Windows 7 Enterprise
  • Thunderbird 24.5.0
  • Lightning 2.6.5
  • No Google Calendar plug-in
  • A few webcal calendars plus a couple of local moz-storage-calendar calendars

After a few wild goose chases, this solved it for me:

  1. For all non-editable calendars, change Properties->Email to "None"
  2. For all editable calendars, set Properties->Email to your email account.

Boom, buttons suddenly appear. For me it seemed that have a Read Only calendar with an email set was preventing the buttons from appearing. I'm not sure what the trigger was - one day it was working then it wasn't. Nothing relevant appears in the error console.

share|improve this answer

As described above I an account has to be associated with the email account receiving that invitation. I had the same problem with "provider for Google Calendar", what cannot be associated with an email address (plz. correct me if you can do) see similar post, at the very end, here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.