Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Emacs does not seem to respect the OS's key repeat rate. I'm using emacs in the terminal. I've set the repeat rate to as fast as possible by directly editing the settings in the following file (I restarted after making the change):

open ~/Library/Preferences/.GlobalPreferences.plist

The rest of the system observes the repeat rate. The terminal works as expected, as does vim. But, when I use emacs I still get the annoyingly slow repeat rate.

share|improve this question
add comment

migrated from stackoverflow.com Oct 18 '12 at 11:28

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 2 down vote accepted

I'm running Emacs 24 and it seems to use the same repeat rate as the terminal, but some of the packages I use slow it down. Try emacs -q (skipping your startup file) and then turn off font-lock-mode and see if it's any better. If it is, then it's Emacs being slow.

share|improve this answer
    
Yeah, skipping the startup file yielded a much faster response. Enabling and disabling font-lock-mode did not cause a change in behavior. I'm glad to know that the problem is not emacs but some bit of configuration. –  Rob Jones Oct 20 '12 at 20:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.