Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have java installed on my computer, but none of my browsers seem to detect it a and I'm not able to run any applets. (Trivial, as it may seem) I've wasted a lot of time googling and trying to troubleshoot this issue unsuccessfully.

This is the output of the java -version command

C:\Users\kraj>java -version
java version "1.7.0_09"
Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)

I'm able to write java programs and run them, Eclipse is running successfully as well - but the only problem is that none of my browsers (chrome, firefox, opera) are not able to detect java. The java website to check java installation in a system is also not detecting java installed in my system. Really appreciate any help/pointers regarding this.

share|improve this question

migrated from stackoverflow.com Oct 18 '12 at 14:12

This question came from our site for professional and enthusiast programmers.

1  
Reinstalling Java might save you the time and effort of getting to the actual issue. :) –  DarkCthulhu Oct 18 '12 at 13:37
    
Checking the JAVA_HOME and PATH env variables isn't so long, though. –  dystroy Oct 18 '12 at 13:38
1  
There is often a configuration option on a browser to enable (or disable) applets. –  rcook Oct 18 '12 at 13:40
    
Hm, this question has just been migrated... You have to create an account here if you want to accept an answer. ;) –  rolve Oct 18 '12 at 14:18
add comment

3 Answers

You have 64-bit Java installed. As most browsers do not come in a 64-bit version yet (this is at least true for Firefox), they are not able to use the 64-bit Java plugin.

If you want to use Java in your 32-bit browsers, you have to install 32-bit Java as well.

Note: It's no problem to have 32-bit Java installed along with your 64-bit version. That way, you may still use the 64-bit version of Eclipse for instance. However, you might have to choose the right VM in eclipse.ini explicitly. See this Wiki entry for more information.

share|improve this answer
    
Most isn't all...Chrome is 64-bit, and you can download nightly 64-bit versions of Firefox for Linux. Other than that, pretty much spot-on. –  Makoto Oct 18 '12 at 13:46
    
I'll try it now, and hope it works! –  Raj Oct 18 '12 at 13:47
add comment

You have 64-bit Java installed, and the web browser(s) that you are using are most likely 32-bit programs.

Install the 32-bit version of Java.

share|improve this answer
add comment

Run this script to verify your situation:

@ECHO off
java -version
ECHO ---------------
SET "JAVA_HOME=C:\Path to wherever\JDKwhatever"
SET "PATH=%JAVA_HOME%\bin;%PATH%"
firefox.exe http://website.with.java
::  iexplore.exe http://website.with.java
pause
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.