Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This option in firefox does not work for many, I read. But at least it did not asks me if I want to close all tabs. Now after the recent update, it asks me every time, even when I disable this option.

I use in imacro TAB CLOSEALLOTHERS command, and now the macro can't go on because of this confirm box.

Is there any way to disable this?

Thank you in advance

share|improve this question

migrated from stackoverflow.com Oct 18 '12 at 15:34

This question came from our site for professional and enthusiast programmers.

    
I made a quick workaround by using greasemonkey and window.close command. Still would be nice to find this out, i'll take a look there thank you –  user1087832 Oct 18 '12 at 9:18
add comment

5 Answers 5

In Firefox 26.0 the annoying warning on closing multiple tabs appeared for "me too" so this still seems to be a source of frustration...

What fixed it for me:

  1. Browsed to the magic about:config page.
  2. Searched for options containing "warnOnClose".
  3. Set both these options to false:

    browser.tabs.warnOnClose           false
    browser.tabs.warnOnCloseOtherTabs  false
    

What did not fix it for me:

Unchecking the preference checkbox:

    Edit > Preferences > Tabs > Warn me when closing multiple tabs

Resetting Firefox:

    Help > Troubleshooting Information > Reset Firefox
share|improve this answer
    
yes, marking browser.tabs.warnOnClose = true worked for me, thanks! –  Edward Tanguay Jun 12 at 15:33
add comment

It is fixed now. Try the latest version of Firefox (16.0.1 as of the time I write this post).

share|improve this answer
    
I have 16.0.2 and it's not fixed yet. –  Saeb Nov 16 '12 at 9:05
    
Strange. It works fine for me. What OS do you have? (I'm not sure this is necessary to know, but...) –  BenjiWiebe Nov 16 '12 at 14:33
    
Windows 7 ultimate 64. The only way I could get rid of the problem was by installing the Tab Mix Plus extension. –  Saeb Nov 17 '12 at 8:38
add comment

Get the Tab Mix Plus extension. That's how I got rid of it when nothing else worked.

share|improve this answer
add comment

This is annoying.

According to

https://bugzilla.mozilla.org/show_bug.cgi?id=277079

it was changed the way that the dialog always comes - regardless of the option in Preferences->Tabs->"Warn me when closing multiplbe tabs".

It is said that it'll be fixed in a later version.

In the meantime you may use the "Close All Tabls (Reloaded)" addon.

share|improve this answer
add comment

get rid of the annoying tabs all together! unter tools - optons- tabs: uncheck all but warn me if new tab would slow down ffx. solved all my tab problems by having them gone.IZ

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.