Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 8 Enterprise (MSDN), behind a proxy.

I configured the proxy in IE network settings (actually, not a proxy, but a .pac file with config), and when trying to connect to the internet, everything works fine in IE - however, the rest of the system seems not to use those settings.

So.. concrete case: add and remove features (like Hyper-V or .Net Framework 3.5) seems to go online for every single feature. This constantly fails. I cannot add any features.

Another concrete example: inside a Hyper-V guest, I cannot get internet access.

It would also be nice, if (on top of that) everything would work correctly (all apps and everything else, like the system, using the same proxy settings).

How can I configure proxy settings for all apps, system, IE etc?

share|improve this question

4 Answers 4

The proxy settings for WinHTTP are not the proxy settings for Microsoft Internet Explorer.
You cannot configure the proxy settings for WinHTTP in the Microsoft Windows Control Panel.
Using the WinHTTP proxy configuration utility does not alter the settings you use for Internet Explorer.

To configure a system wide proxy do

netsh winhttp set proxy myproxy


if you want to use IE proxy settings for all programs, try

netsh winhttp import proxy source =ie


more information here:

share|improve this answer

Is IE set as the default browser? If not, set it and check again.

If it still doesn't work, in Windows 7 at least the following command helps:

netsh winhttp import proxy source=ie

You can also use netsh winhttp show proxy and netsh winhttp reset proxy (purpose should be evident).

share|improve this answer
(I am using Win 8.) Using the show proxy command, I get "Direct access (no proxy server). Which is wrong of course, I am using a proxy settings file in the network (.pac). Also, IE is default. –  Andreas Reiff Oct 19 '12 at 6:45
show proxy says no proxy? That's weird. Hmm, just thought of something - in Win8 there are two copies of IE - desktop and Metro. Maybe you need to specify the proxy for both (in case you haven't)? –  Karan Oct 19 '12 at 17:00
I could not find such settings for Metro IE, I suppose, it takes the same as the desktop IE. Also, I read somewhere else that each program uses their own proxy settings. Which would be very cumbersome and also mean that programs that do not have that option are going to fail.. –  Andreas Reiff Nov 13 '12 at 11:43

You shoud configure both PAC file for IE and proxy server ip address in IE settings for other application in your system except IE. IE will use PAC file, and others in system will use configured proxy server.

share|improve this answer
only few programs use IE settings. even windows itself seems very good when using the proxy for activation, but bad when using the proxy for update (though this works.. sluggishly..) –  Andreas Reiff Jul 25 '13 at 17:36

Most desktop apps integrated in windows 8.1 share the same proxy setting with IE.

- For a system wide proxy you need first manually set IE proxy.
- You can also use 'PAC' proxy settings instead.

For the metro apps which live in a closed container, they do NOT use any proxy to connect by default.

- Because they are forbidden to send network traffic to the local computer in case of improper connection.
- This defies the use of loopback method, hence the proxy.

There is a 'loopback exempt' mechnism though in Windows 8.1 to avoid this dilemma.

- You can use the command-line tool called 'checknetisolation' to add certain app to the exempt list.
- The exempted metro app uses IE proxy to connect by default.
- There are third-party tools to do this job at ease.
- The tool 'fiddler' for example is recommened for this purpose.

You can download fiddler here:

- Install and open it
- click 'win8 config'
- check the box behind which is the app you want to exempt.
- save config.
- If you want to set another proxy than IE, you can also fill the proxy address in the same page.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.