Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Evolution an email can be labeled by selecting from a pop-up menu. New items can be added right there on the menu. The new label is then added to the bottom of the list.

I would like to re-order my labels (or at least have them sorted alphabetically), but haven't been able to find a way to to this.

I am using Evolution 2.22.3.1 on Ubuntu.

share|improve this question
up vote 0 down vote accepted

The labels are stored in ~/.gconf/apps/evolution/mail/%gconf.xml. Here's the defaults, plus 1:

<entry name="labels" mtime="1254501809" type="list" ltype="string">
        <li type="string">
                <stringvalue>I_mportant:#EF2929|$Labelimportant</stringvalue>
        </li>
        <li type="string">
                <stringvalue>_Work:#F57900|$Labelwork</stringvalue>
        </li>
        <li type="string">
                <stringvalue>_Personal:#4E9A06|$Labelpersonal</stringvalue>
        </li>
        <li type="string">
                <stringvalue>_To Do:#3465A4|$Labeltodo</stringvalue>
        </li>
        <li type="string">
                <stringvalue>_Later:#75507B|$Labellater</stringvalue>
        </li>
        <li type="string">
                <stringvalue>_Junk:#42b2adbc5aa4|_junk</stringvalue>
        </li>
</entry>

I added junk from within the evolution preferences window. When I add an entry manually here, or when I change the order of the entries, they appear to be overwritten by something. Even changing the 'mtime' attribute - the attruibute gets reset to it's 'pre edited by me' value.

Using gconftool-2:

gconftool-2 --dump /apps/evolution > mail-prefs.xml

edit the xml file in your favorite text editor. Then:

gconftool-2 --load mail-prefs.xml

This worked for me on ubuntu 9.05, evolution 2.26.1

share|improve this answer
    
Thanks, it worked! – Dawie Strauss Oct 5 '09 at 7:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .