Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the Recycle Bin, I sorted by 'Date Modified', but the result is not in the proper order. It was neither ascending nor descending. Other sorts (by Date deleted, size, item type) all work well. Does anybody have the same problem?

share|improve this question
Wow, just added that column and I see that you're absolutely correct - it doesn't sort properly by Date Modified at all! If some columns are not allowed for the Recycle Bin, why does Windows allow users to add them in the first place? – Karan Oct 19 '12 at 17:46
Did you find what order the files are sorted when you try sorting by 'date modified'? – user67275 Oct 20 '12 at 16:20
I couldn't make out for sure. It seems that Date Modified is being used as a secondary sort order, but what the primary sort is wasn't all that clear. I'll have to check further. It would also help if someone else can confirm this. – Karan Oct 20 '12 at 20:36
If some columns are not allowed for the Recycle Bin, why does Windows allow users to add them in the first place? @Karan, why wouldn’t it be allowed? It was not only allowed, but enabled by default in XP and it worked just fine. This is simply a defect, a bug in Windows 7 (maybe the reason they hid the column by default). Moreover, there is no reason for it to exist, so it is a big oversight. You would think that they would have caught and fixed it in SP1, but nope. Let’s hope that SP2 (if they make one) will fix it. – Synetech Aug 22 '13 at 18:48

This is because Windows creates sub groups for the deleted items: "Today", "Last Week", "Earlier this Year" and then sorts upon these groupings as the dates apply. These groups can be changed by opening the Recycle Bin > right click the open white space > Hover over Group by > and choosing your preferred sorting method. To allow proper sorting for date modified you can choose the None option. This should allow you to sort "Date Modified" correctly. Keep in mind that some of these group sorting methods do not readily show that they are in groups, such as the group named "Original Location".

share|improve this answer

OK, got it. Choose "Date last saved" from the More dialog in the column chooser. Choose Group by None and the date sort now works. Not perfect but good enough!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .