Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Upgraded to 10.6 recently. 10.5 would connect to my home network whenever I was home. 10.6 constantly pops up the network selection dialog and asks me what network I want to join. I click my home network and the password is already entered (so it "remembers" the network). "Remember network" is checked... but it does it every time.

How do I get 10.6 to connect to networks automatically whenever it sees them?

share|improve this question

2 Answers 2

See if http://osxdaily.com/2012/02/15/fix-for-mac-os-x-not-remembering-wireless-networks/ helps. It references 10.7, but maybe the root cause for your issue is the same.

share|improve this answer
    
Repaiting disk permission as we speak. Thanks for the suggestion. Will accept if it fixes! –  Hendy Oct 19 '12 at 17:33
    
Repaired permissions about 10 times and no dice. –  Hendy Oct 23 '12 at 12:19
    
If it were me, I think I would try some of the more common wireless remedies, e.g., various combinations of switching to a new location, removing & recreating the wireless network, starting from scratch (remove com.apple.airport.preferences.plist to remove all remembered networks). –  Brenda Bell Oct 28 '12 at 13:25
  1. Use Brenda's tip = trash com.apple.airport.preferences.plist to rid remembered networks.
  2. Reboot your computer.
  3. Go to System Preferences → Network. If necessary, enter your password to Unlock (in order to make changes).
  4. Click Advanced.
  5. Deselect "Remember any networks this computer has joined".
  6. Highlight the Network Name you use most often.
  7. Drag this network up into the 1st position atop any and all others.
  8. Click on "Turn AirPort Off" in order to deactivate your AirPort.
  9. In the left-hand column highlight Airport.
  10. Click Advanced.
  11. Select the TCP/IP tab.
  12. For the "Configure IPv4:" select "Using DHCP" and then click OK.
  13. Then on the next screen that appears, click Apply and close System Preferences.
  14. Control-Click (i.e., right-click) on your Airport menu item.
  15. Turn on your AirPort.
  16. Select your chosen wireless network to join (enter password if requested to do so).

You ought to be able to get connected now.

Tricky since simplistic resolution to a ubiquitous and prevalent problem of Mac's losing their nice networking behavior.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.